Ir ao conteúdo
  • Cadastre-se
rafaelfjorge

RESOLVIDO Site interno em wordpress usando o wampserver

Recommended Posts

Boa Tarde, 

 

  Caros, vou abrir esse tópico como ultima solução. 

 Estou montando um site em wordpress usando a maquina local como servidor (Localhost)
Estou usando o wordpress (wordpress-4.9.6-pt_BR) e o wampserver 3.1.3 tendo Apache 2.4.33 - PHP 5.6.35, MySQL 5.7.21 MariaDB 10.2.14
PHP 5.6.35 for CLI (Command-Line Interface)

 Configurei o site em localhost e um teste pelo meu ip, como aqui não usamos ip fixo, estou usando o My-Ip. 

 Então, na minha maquina abre normal o site, mas quando vou acessar de outra maquina na mesma rede, apresenta a mensagem.
Forbidden

you don't have permission to access/testedois on the server.

Apache/2.4.33(win64) PHP/5.6.35 serverat 192.168.0.18 Port 80

 

Testei a porta 80, esta sendo usada pelo PID 916 que é o httpd.exe

Fui no meu firewall e criei regra de entrada para a rede no TCP e UDP e no modem CISCO também fiz a libertação desta porta conforme ip da maquina, ainda dando o mesmo erro de acesso, fiz macumba, alterei a porta, voltei para a 80, rezei pra Thannatos, chorei, deitei em posição fetal e cá estou. 

Ps. Sou programador, entendo básico de nada em redes, toda vez que subia um site o servidor já estava configurado. 

 

Existe alguma regra que estou pulando ou eu que estou noobando mesmo??

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde.

 

Utilize o IP ao invés do My-IP. Exemplo, "192.168.1.3/site/". Desabilite temporariamente o Firewall para testes.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz isso também mano, usei meu Ip e desabilitei o My-ip, mesmo assim não entra na mesma rede. 
 Hoje fiz o teste com outra porta, todas que coloco elas ficam na tasklist pelo processo do apache e php, porém não abre em outro pc na mesma rede. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você "chamou" a outra porta através da url? Exemplo: "192.168.1.3:8081/site/".

 

Em 10/07/2018 às 15:28, ciro-mota disse:

Desabilite temporariamente o Firewall para testes.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim sim, mesmo assim deu erro de acesso na porta 80, ai o q eu fiz. 

 Desinstalei tudo, refiz tudo por um tutorial na internet de instalação do wordpress pelo wamppserver. Agora o site abre s´[o na minha maquina, meu ip não pinga nas demais maquinas na mesma rede, acredito que seja só isso para resolver, eu ainda estou na busca eterna pela felicidade de um acesso host. kkk

Esse tutorial é muito bom, fiz ate um alias para chamar com o nome que eu quero ao invés de chamar pelo nome da pasta no "www", porém não acessa em outra maquina na mesma rede. 
 Se tiver um norte para o meu problema, eu fico muito feliz. 

Mano, meu e-mail rafaelshaken@gmail.com caso você tenha algum material que possa me ajudar. 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Meu amigo, isso deu dor de cabeça, procurei em foruns, liguei para BDas, analistas de rede e todo mundo dava a mesma resposta que não adiantava, ai em um belo dia logo pensei, se preciso liberar acesso, vou futricar todos os arquivos que permitem somente o acesso local. fiz uma maquina virtual e editava arquivo por arquivo e testava, apagava e reinstalava do zero, até que um belo dia achei o arquivo "X" que precisava de fato permitir o acesso. 

 Vou deixar publicado aqui a solução, porque vi q na internet muita gente passa por isso e ninguém tem uma solução. 
Espero que ajude. 

Primeiro eu habilitei no wamp a opção de colocar o site on/off fiz o seguinte. 

Botão direito no ícone do wamp > Opções do wamp > mostrar: Online / Offline
 (Habilitei essa opção para garantir deixar o site online)
Depois cliquei com o botão direito no ícone wamp > apache > httpd-vhost.conf >> Ao abrir esse arquivo eu inclui permissão com o comando "Require all granted" Ficando assim:

# Virtual Hosts
#
<VirtualHost *:80>
  ServerName localhost
  ServerAlias localhost
  DocumentRoot "${INSTALL_DIR}/www"
  <Directory "${INSTALL_DIR}/www/">
    Options +Indexes +Includes +FollowSymLinks +MultiViews
    AllowOverride All
    Require all granted
  </Directory>
</VirtualHost>
 

 

pimba, funcionou na rede local sem precisar mudar porta, fazer macumba ou pular 7 ondas. 
 Logico, seguindo os passos, liberar porta no firewall, configurando o wordpress e tal. 
 

Espero que isso ajude os demais usuários que tiverem o mesmo problema. 
 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×