Ir ao conteúdo
  • Cadastre-se
Lucas Da Silva Aleixo

VisualG Salvar saída em arquivo (.txt)

Recommended Posts

Gostaria de saber se é possível salvar a saída de um algoritmo em um arquivo (.txt)?

 

EXEMPLO:

 

- ALGORITMO

algoritmo "semnome"
var
  x :inteiro
inicio
  escreva("Digite um valor: ")
    leia(x)
      escreval(x)
fimalgoritmo

- SAÍDA

Digite um valor: 1
 1

Teria como salvar a saída em um arquivo (.txt)?

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lucas Da Silva Aleixo    no visualg existe o comando arquivo ,  mas ele é bem limitado e difícil de usar   ,  pelo que vi ele serve para ler o arquivo e colocar o valor lido na variável do comando leia que estiver no programa , então crie um arquivo txt no bloco de notas e escreva alguma coisa nele e salve ele com o nome que você quiser e depois coloque no código o caminho para o arquivo , testei com esse código :

algoritmo "lendo do arquivo"
  arquivo "c:\testeArquivos2.txt"
  var x,y: inteiro
inicio
  para x de 1 ate 5 faca
    escreva("digite algo ")
    leia (y)
    escreval("valor no arquivo ",y)
  fimpara
fimalgoritmo

e usei esse arquivo para testar :

5b46aa38946e8_arquivovisualg.jpg.e06de3b1ca91e8364b074ff173e010bb.jpg

e ele leu o que está no arquivo e imprimiu todos os dados do arquivo , sendo um a cada vez que o comando leia foi executado ,  sendo assim ele não serve para o que você quer pois ele não salvou o arquivo , mas apenas leu o que estava no arquivo  , então se você quer usar arquivos é melhor usar outro compilador .

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Niê disse:

E tem como salvar um Leia dentro de um txt?

 

Como assim? tente explicar melhor.

 

O leia() é uma estrutura que "ler algo do teclado ou do arquivo e joga na variável". No exemplo do @devair1010, o leia() vai ler do arquivo enquanto existir dados nele, ao terminar, passa a ler do teclado.

 

 

 

@Lucas Da Silva Aleixo, sobre:

18 horas atrás, Lucas Da Silva Aleixo disse:

Gostaria de saber se é possível salvar a saída de um algoritmo em um arquivo (.txt)?

 

Teria que ver qual o contexto da necessidade.. Para que quer salvar em arquivos? tem como dar um exemplo mais específico?

 

O uso de arquivo no Visualg é muito limitado... não dá para, por exemplo, usar o programa normalmente, e no final usar um arquivo para salvar os dados (pelo menos eu desconheço)... lá, só dá para usar o arquivo no início e de uma vez só.

 

Sugeriria utilizar o Pascal, que é muito mais robusta... é bem próximo do Visualg, só muda que os comandos são em inglês. (obs.: o Visualg é meio que uma tentativa de "traduzir" o Pascal, ou seja, utilizando os comandos em Português para assim deixar "mais amigável", mas a estrutura da linguagem é bem próximo...).

 

Ou parte para o C ou C++... que é mais popular...

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×