Ir ao conteúdo
  • Cadastre-se
robersa_

Excel valores exclusivos com cont.ses para critérios

Recommended Posts

Boa noite, tenho uma planilha de produtos:
Gostaria de fazer a contagem de um determinado produto (Combo) onde ele me retornasse a quantidade de combos vendidos:
Se um cliente compra um combo com 3 produtos (por exemplo) o CPF dele vai se repetir para cada produto do combo, mas só deve ser contado 1 para esse cliente.
Se um cliente compra dois combos, 1 combo com (2 produtos, por exemplo) e outro combo com (3 produtos, por exemplo), o CPF dele vai se repetir 5 vezes, mas deve ser contado como dois, por serem dois combos.
Para distinguir isso, primeiro eu preciso contar valores exclusivos para os casos que o cliente só compra 1 combo.
Consegui isso através dessa fórmula: =SOMA(SE(FREQÜÊNCIA(($E$2:$E$11=$E$2)*(CORRESP($C$2:$C$11;$C$2:$C$11;0));($E$2:$E$11=$E$2)*(CORRESP($C$2:$C$11;$C$2:$C$11;0)))>0;1;0))

 

Mas preciso de mais duas coisas e não consigo inserir na fórmula,

Primeiro: Preciso separar a quantidade de combos por supervisor (quantos combos um supervisor vendeu em determinado intervalo);

Segundo: Preciso contar mais de 1, caso o mesmo cliente compre outro combo, para isso tem uma coluna chave, que é exclusiva para cada combo.

 

Alguém poderia me ajudar a formular isso!?
Grato!

Modelo.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia @robersa_

 

Lembre-se que entendemos um pouco de Excel, mas estamos por fora do assunto da tua planilha, normalmente as pessoas demonstram manulamente na planilha o resultado esperado e  quais os dados envolvidos.

Outra coisa, para retornar quantos combos o  supervisor vendeu em determinado período, é necessário ter uma coluna com datas.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 18/07/2018 às 08:30, R0DR1G0_CWB disse:

Olá, já tentou usar a tabela dinâmica?

você resolve facilmente esse dilema com a Contagem Distinta.

 

Veja o exemplo:

Modelo Solução.xlsx

 

É só você adaptar para sua necessidade...

Com tabela dinamica eu consigo o resultado, mas a planilha vai envolver outras resultados, e a tabela dinamica não se torna interessante.
Mas agradeço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×