Ir ao conteúdo
  • Cadastre-se
Italo022

Excel Macro para verificação de item em outro arquivo

Recommended Posts

Boa tarde,

 

Eu gostaria de criar uma macro em VBA a fim de verificar se o item da coluna A da plan1 se encontra na coluna A da plan 2, e caso positivo, retornasse na coluna B e (linha correspondente) da plan 1 a expressão "é amigo".

Note que são arquivos diferente.

Grato desde já

plan1.xlsx

plan2.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, pois eu tenho que criar uma rotina e também tenho que usar para outros arquivos, por isso também gostaria do uso pelo VBA. Mas qualquer outra maneira é válida para aprendizado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia, @Italo022

 

Com formulas é bem fácil, copie e cole a formula abaixo na célula B1 da Plan1 e arraste até a célula A15.

=SE(ÉERROS(CORRESP(A1;[plan2.xlsx]Plan1!$A$3:$A$6;0));"";"Amigos")

Não se esqueça de clicar em Curtir.

 

Dê retorno.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×