Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
cisneiro

HTML RESOLVIDO Modificar uma "div" através do CSS.

Recommended Posts

Boa tarde a todos do fórum, galera estou tentando criar meu primeiro site usando a IDE sublime text 2. Logo , tenho um arquivo HTML e outro CSS para estilizar a página. porém no CSS só consigo inserir os atributos na primeira "div"( id:wrep) do html, quando tento estilizar a seguda (id:"content") e terceira (id:"sidebar") "div", nada funciona quando atualizo a pagina no navegador. abaixo segue os códigos do arquivo HTML e o código do CSS. quem puder ajudar agradeço. aguardo atenciosamente a ajuda dos senhores, obrigado

 

HTML

<!doctype html>

	<html>
		<head>
			<title>Meu primeiro layout</title>
			<meta charset = "utf-8"/> 
			<link rel="stylesheet" type="text/css" href="estilo.css"/>

		</head>

		<body>
			<div id="wrap">
				<header>
					<h1>Nome do site</h1>
					<nav>
						<ul>
							<li><a href="">Menu 1</a></li>
							<li><a href="">Menu 2</a></li>
							<li><a href="">Menu 3</a></li>
							<li><a href="">Menu 4</a></li>
							<li><a href="">Menu 5</a></li>
						</ul>
					</nav>
				</header>


				<div id:"content">
					<section>
						<h2>Título da seção</h2>
						<p>Conteúdo da seção</p>	
					</section>
					<article>
						<h2>Título do artigo</h2>
						<p>Conteúdo do artigo</p>
					</article>
				</div>
				<div id:"sidebar">
					<aside>
						<ul>
							<li><a href="">Submenu 1</a></li>
							<li><a href="">Submenu 2</a></li>
							<li><a href="">Submenu 3</a></li>
							<li><a href="">Submenu 4</a></li>
							<li><a href="">Submenu 5</a></li>	
						</ul>
					</aside>
				</div>


				<footer>
					rodapé do site
				</footer>
			</div>
		</body>

	</html>

 

CSS

 

body{ font-family: helvetica, sans-serif; 

}
#wrap{
	width: 960px;
	margin: auto;
	background: #e3e3e3;
	padding: 10px 20px;
	overflow: hidden;
}
header nav ul{
	list-style: none;
	padding-left:  0;
}
header nav ul li{
	display: inline-block;
	margin-right: 10px;
}
header nav ul li a{
	font-size: 20px;
	color: #ff6600;
	text-decoration: none;
}
header nav ul li a:hover{
	text-decoration: underline;
}
#content{
	float: right;
	width: 660px;
	background: blue;
}

#sidebar{
	float: right;
	width: 300px;
	background: blue;
}

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Opa, boa tarde cisneiro

 

Fico feliz que esteja iniciando sua vida no mundo de desenvolvimento. Acredito que o problema no seu caso, está na forma em você estruturou o código mesmo. As divs, devem seguir a seguinte estrutura de criação:

 

<div id="nome">
  <p>Conteúdo</p>
</div>

 

Note que no seu código, você está usando para declarar a criação de duas das divas, conforme abaixo:

 

<div id:"content">
  <!-- Toda sua estrutura -->
</div>

Conforme expliquei, o certo seria então:

 

<div id="content">
  <!-- Sua estrutura -->
</div>

Em HTML, todos os atributos de uma tag serão tratados da mesma forma, utilizando um = para definir o valor daquele atributo. Espero que isso funcione!

 

Qualquer coisa dúvida, é só postar que tentamos te ajudar.

 

Abraços!

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

@cisneiro  Basicamente não funciona por causa do "dois pontos" que foi mencionado pelo@XenoStory

 

O certo é usar o sinal de igual " = " porém já vi em certos casos usar o dois pontos " : " provavelmente com algum framework.

Mas no HTML o correto é o sinal de igual. :thumbsup:

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Galera primeiramente quero agradecer a todos que responderam. Na verdade eu que fiz confusão e fui desatento com o HTML e CSS, pois no CSS usamos os : antes do valor do atributo e no HTML é o sinal de igual.

 

Muito obrigado galera, pois estava travado por conta deste pequeno detalhe.

 

Cordialmente Allan Cisneiro.

@XenoStory @DiF @Luís Roberto C. da Silva

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×