Ir ao conteúdo
  • Cadastre-se
Kris Wannieg

Erro de reconhecimento ao configurar as teclas em programas

Recommended Posts

 Olá, pessoal, estou com um problema no meu PC desde ontem que até agora não consegui achar uma solução tanto nas minhas tentativas tanto via Google.

 

O problema: Em certos programas (Discord, jogos) as teclas pressionadas são reconhecidas erroneamente. Se aperto "[" por exemplo, ele reconhece "]", ";" vira "/' e se aperto "/" aparece "UNK193" (provavelmente de Unknown = Desconhecido). Não são todas as teclas que dão erro, mas várias. O erro acontece apenas em aplicativos (para ser justa só testei no Discord e no CSGo pois era o que eu tinha disponível), se abro o Bloco de Notas ou até aqui no navegador, o problema não aparece. De fato, se eu digitar no chat do Discord funciona tudo normal, só aparece quando tento configurar o Push to Talk (no CS o erro também apareceu quando tentei configurar as teclas).  O problema não é o teclado já que o erro persiste com outros teclados ou até mesmo o Teclado Virtual do Windows. Um detalhe: Se vou no Gerenciador de Dispositivos > Teclados aparecem quatro "Dispositivo de Teclado HID", imagino que o correto seria apenas um.

 

Quando aconteceu: Meu PC possuía um HD 500GB 5900 RPM, ontem adicionei dois novos: Um HD 160 GB 7200RPM (antigo que estava no meu segundo PC) e um SSD A400 120GB (novo). Conectei os dois novos discos no gabinete, liguei o PC, BIOS reconheceu os três, coloquei para formatar já que queria o Windows no HD de 160GB (o SSD ficará apenas para jogos de loading lentos) instalei tudo normalmente, drivers, programas e só fui notar o problema quando abri o discord para jogar.

 

O que já fiz: Troquei o teclado, testei com teclado virtual, formatei várias vezes testando o Windows no HD de 160 e depois no de 500, depois desativando (tanto na BIOS quanto desligando dentro do gabinete) o SSD e o HD de 160GB e usando apenas o meu antigo. Usar o CCleaner para limpar os registros, colocar a BIOS para escolher as opções padrões. Algumas limpezas de HD que achei online (não lembro o código, desculpa), verificar o Idioma (ABNT2) e desinstalar os Dispositivo de Teclado HID (neste caso o teclado parou de funcionar até eu tirar e colocar de novo o USB e então voltou os quatro). Entre outras coisas que já nem lembro mais (estou tentando resolver desde ontem).

 

Se alguém tiver qualquer noção do que pode ser/como resolver, no momento estou aceitando qualquer dica.

 

PC:

i5 6600

H110M-C/BR Asus

1x8GB DDR4 HyperX Fury 2133mhz

GTX 1060 6GB Galax OC

Seasonic S12II 620w

Windows 8.1 Pro 64Bits

HDs:

Seagate 500GB 5900 RPM (já estava no PC, funcionando normalmente até a formatação/adição de novos)

160 GB 7200RPM (não conheço a marca, este estava no meu PC secundário, aparentemente funcionando, porém como o PC em que estava era usado apenas para navegação, se o problema estivesse nele, não teria como saber)

SSD 120GB Kingston A400 (comprado ontem, ainda na garantia se for o caso)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois é, o estranho é que acontece no Windows 8.1 e no 10 e reparei que não é em todos os programas. GTAV reconhece as teclas normalmente, Steam, Discord e CSGo dão o erro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×