Ir ao conteúdo
  • Cadastre-se
GuiMamede

Excel Unificar dados de células em uma planilha a partir de muitos arquivos diferentes

Recommended Posts

Olá,

Preciso descobrir dados estatísticos simples (como média e desvio padrão) e também criar alguns gráficos comparativos com dados contidos em aproximadamente 250 arquivos .xlsx diferentes. Não irei precisar de todos os dados de cada planilha, apenas algumas células específicas.
A única forma que eu sei é criando uma fórmula em uma célula, como por exemplo: =MÉDIA([arquivo1xlxs]Planilha1!A2;[arquivo2xlxs]Planilha1!A2)

Mas escrever o nome de cada um dos 250 arquivos e suas respectivas planilhas vai tornar meu trabalho inviável.

O que eu gostaria de fazer é, por exemplo, juntar todos os 250 dados das diferentes células A2 da Planilha1 em uma única planilha.

 

Alguém teria uma sugestão?
Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @CasaDoHardware , obrigado pela resposta. O Power Query já vem embutido no Excel 2016, no "obter e transforar", que é a versão que eu tenho, não é isso? Mas ainda assim, não sei como fazer para unificar em uma planilha os valores de um determinada célula (A2, por exemplo) de diferentes planilhas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×