Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
sdadsd

VisualG problema com sintaxe no visualg

Recommended Posts

Alguém poderia me ajudar para que essas sequencias funcionem? 

Para mim parece certo, mas quando coloco para executar da errado. 

Capturar.PNG

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@sdadsd    essa parte do seu código está certa ,  provavelmente  o erro seja em outro comando ,  se você puder poste o código todo , assim poderemos ver onde está o erro  .

Compartilhar este post


Link para o post
Compartilhar em outros sites

aqui o programa inteiro:

Capturar.PNG

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@sdadsd      para postar seu código seria melhor você postar seu código em forma de texto  pois com imagem não tem como copiar  então use o botão   <>   que está lá na barra de ferramentas da janela de postar pois senão seu código fica faltando alguns caracteres , e essa variável TS não pode ficar dentro de parênteses como está  não sei bem o motivo ,  mas o que importa é que para rodar seu código remova os parênteses dessa variável .

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 01/08/2018 às 19:11, sdadsd disse:

Para mim parece certo, mas quando coloco para executar da errado. 

 

O que dá errado? como é que deveria dar se estivesse dando certo?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você precisa tirar os parênteses do TS. Os parênteses geralmente colocamos quando temos que realizar contas.

 

Veja como ficou:

algoritmo "semnome"
// Função :
// Autor :
// Data : 03/08/2018
// Seção de Declarações
var
A, B, R, TS :real
inicio
escreval(" ==============")
escreval(" = Exemplo_SE =")
escreval(" ==============")
escreval()

escreval(" - Entre com 2 números quaisquer:")
escreval()
escreva(" * ")
leia(A)
escreva(" * ")
leia(B)

escreval()

escreval(" - Somando:")
R <- (A + B)

se (R > 30) então
   TS <- (R + 5)
senao
   TS <- (R - 5)
fimse

escreval()

escreval(" * O resultado é:", TS)
escreval(" * Fim do Processo")
fimalgoritmo

Testei aqui e deu certo.

Editado por Lucas Da Silva Aleixo
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lucas Da Silva Aleixo Arrumei como você colocou, mas aqui o resultado é igual a zero com qualquer número.

adicionado 1 minuto depois

@Simon Viegas Da errado pelo resultado ser 0, quando deveria ser algum número + 5 ou -5 

Editado por sdadsd
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@sdadsd      o código do @Lucas Da Silva Aleixo     está certo , testei aqui e ele funciona bem ,  provável que tenha algum erro no seu código ,   se você puder poste seu código para que possamos ver como está e em que podemos ajudar .

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×