Ir ao conteúdo
  • Cadastre-se
glaucicas

Excel RESOLVIDO Fórmula Somase somando errado - Excel 2016 MAC

Recommended Posts

Eu sei que parece impossível, mas a fórmula Somase não está fazendo o cálculo correto e não sei se é um bug ou algo que estou fazendo de errado. Uso o excel 2016 para MAC (com o 2011 ocorria o mesmo) e possuo uma planilha com valores a pagar e o lançamento do pagamento, então há valores negativos e um valor positivo (geralmente o valor total da dívida). Uso o Somase porque preciso do critério da data, mas a soma nunca está correta quando o valor do pagamento está próximo ou igual o valor da dívida, mas quando uso a função Soma para os mesmos valores, o valor fica correto. 

 

image.png.4b12f700a24de4119bba15f76597251c.png

=SOMA(D1:D17)

 

 

image.png.46fb22bb6e44647ad81657df8a418263.png

=SOMASE(C1:C17;43359;D1:D17)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz um teste aqui e funcionou perfeitamente.

 

Basta formatar a célula onde a fórmula foi inserida para NÚMERO com duas casas decimais.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ssporch você também usou o Excel 2016 Mac? Tenho outras funções na planilha que dependem que o valor esteja correto, ou seja zerado, para confirmar que não há mais dívidas em aberto naquele mês, por isso, formatar a célula para duas casas decimais apenas mascara o valor na visualização.

adicionado 2 minutos depois

@fessenden as linhas e colunas estão na pergunta original tanto com o total usando a fórmula Soma quanto com o total usando a fórmula Somase. Você precisaria de algo diferente?

Para mim é muito importante que o valor esteja correto porque a tabela é bem grande e tenho um menu que retorna as dívidas que ainda estão abertas.

Editado por glaucicas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Usei o Excel  2010 for Windows, já que você disse que também ocorria o mesmo erro na versão 2010.

 

E não entendi a questão de "mascarar a resposta",  pois, no teste feito usando os dados que você postou, o resultado é mesmo ZERO!!!!

Editado por ssporch

Compartilhar este post


Link para o post
Compartilhar em outros sites

O Excel 2011 que tinha usado tambem era Mac.

 

E o problema é que para mim quando uso o Somase NÃO dá zero. Por exemplo, a soma dos valores negativos dá -902,03. Mas quando lanço um valor positivo de 902,03, ao invés de contabilizar ZERO, ele mostrar um valor de image.png.03a705804d3a01c533108f22a20f9bb4.png . Fiz alguns testes, e quando jogo um valor positivo de até 817,00 a fórmula SOMASE contabiliza corretamente, mas de 817,00 para cima ele começa a errar o cáculo. Por exemplo, quanto jogo o valor positivo de 900,00 ao invés de retornar -2,03 a fórmula retorna image.png.fd589975e93565bbe81675e6b2c5b875.png. E tenho certeza que os valores foram lançados corretos, porque quando uso a fómula SOMA, os valores retornados estão corretos.

 

Não sei se é um bug fo SOMASE do EXCEL MAC

 

 

Editado por glaucicas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse Office está instalado no computador da empresa ou pessoal?

 

Se a licença foi comprada legalmente, que tal entrar em contato com o Suporte da Microsoft?

 

Parece ser claramente um BUG!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse problema é tão antigo quanto o Excel e não chega a ser exatamente um Bug. Veja por exemplo o que ocorre se você digitar a simples fórmula

= 8,1 - 7,4

 Para saber porquê isso acontece e formas de contornar:

 

Aritmética de ponto flutuante pode fornecer resultados imprecisos no Excel

Como corrigir erros de arredondamento na aritmética de ponto flutuante

Editado por Edson Luiz Branco

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×