Ir ao conteúdo
  • Cadastre-se
Arthur Brunhara

Portugol Exercício - Algoritmo - Estrutura de Repetição Para

Recommended Posts

Alguém poderia me ajudar com estes exercícios? 

 

1) Elabore um algoritmo que leia um conjunto de 150 números inteiros e positivos fornecidos pelo usuário. Calcular e apresentar a soma dos números pares, impares  e a soma desses dois resultados

2) Uma empresa decide dar um aumento de 30% aos funcionários cujo salário seja inferior a 1500 reais. Elabore um algoritmo que possa efetuar o cálculo do salário reajustado de cada funcionário e o total de funcionários que receberam o reajuste, sabendo que a empresa possui 2000 colaboradores. 

 

As respostas devem ser em pseudocódigo e os algoritmos devem ser feitos com a estrutura de repetição Para

 

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

E qual é a dúvida? O que conseguiu fazer até agora?

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
15 horas atrás, Arthur Brunhara disse:

1) Elabore um algoritmo que leia um conjunto de 150 números inteiros e positivos fornecidos pelo usuário. Calcular e apresentar a soma dos números pares, impares  e a soma desses dois resultados

 

Tem (pelo menos) duas abordagens:

- ou armazena os 150 números num vetor e faz as verificações posteriormente;

- ou utiliza uma variável para ler cada número, e na medida que vai lendo, já vai verificando. 

 

A definição de uma opção e outra geralmente está relacionada ao que está estudando no momento... se já estou vetores ou está estudando nesse momento, faz mais sentido utilizar vetores. Se ainda não estudou, vai de variável simples.

 

Segue um esboço:

algoritmo "semnome"
// Disciplina  : <preencher>
// Professor   : <preencher>
// Descrição   : Resolução de exercício:
      //Elabore um algoritmo que leia um conjunto de 150 números inteiros e
      //positivos fornecidos pelo usuário. Calcular e apresentar a soma dos
      //números pares, impares  e a soma desses dois resultados
// Autor(a)    : Luís Roberto C. da Silva
//               (com colaboração do Fórum do Clube do Hardware)
// Data atual  : 21/08/2018
var
   numeros :vetor [1..150] de inteiro //variável para armazenar os números
   
   i  :inteiro //auxiliar para percorrer o vetor

inicio

//LER OS 150 NÚMEROS QUE SERÃO ANALISADOS
escreval("Digite os 150 números: ")
para i de 1 ate 5 faca //OBS.: Deixei com 5 para facilitar os testes iniciais
   leia(numeros[i])
fimPara

//CALCULA A SOMA DOS NÚMEROS PARES
para i de 1 ate 5 faca //OBS.: Deixei com 5 para facilitar os testes iniciais

   //Aqui verifica se o número é PAR. Se sim, vai acumulando a soma destes
   
fimPara


//EXIBE OS RESULTADOS

//Aqui exibe os resultados




fimAlgoritmo

 

 

OBSERVAÇÕES IMPORTANTES:

  1. Esse código está em Visualg, ou seja, é uma espécie de "pseudocódigo" específico... a depender terá que adaptar para à sintaxe do Portugol utilizando por você;
  2. O código é só um esboço... para dar ideias iniciais. Perceba que, por exemplo, não coloquei para verificar se os números são inteiros e positivos ou não, entre outros detalhes.
  3. Você pode efetuar as somas dos pares, e ímpares de uma vez só. Mas inicialmente pode fazer apenas com pares, depois insere os ímpares...

 

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×