Ir ao conteúdo
  • Cadastre-se
Faelstr07

Excel RESOLVIDO Automatização de uma planilha

Recommended Posts

Olá, tudo bem?

Estou precisando de uma grande ajuda com o Excel, eu tenho uma planilha de frequência onde quero que em uma célula seja determinado uma quantidade máxima de faltas consecutivas, e a partir disso, quando eu for preenchendo a tabela, quanto atingir a quantidade de faltas determinadas, a situação do aluno seja DESLIGADO, segue em anexo uma planilha com o exemplo para facilitar.

Acho que a forma mais viável seja a utilização do VBA, mas fica a critério.

Pode também definir o critério de busca (no caso o número de faltas) em várias células, não necessariamente em uma única.

Desde já, agradeço!

 

edit. No anexo agora tem uma fórmula que recebi aqui no fórum, o que me resta é automatizar o número de faltas que eu determinar na célula G7.

 

 

Exemplo 1.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dei uma olhada rapidamente na sua planilha, mas meu expediente está encerrando. Amigo, algumas dicas que podem te auxiliar até alguém mais avançado aparecer por aqui.

 Você pode considerar o número 1 como falta e o 0 como presença, pois é mais complexo criar uma fórmula para somar texto. A partir disto, você pode usar um "somase", considerando "1" como falta. E lá em baixo, na célula G7, sugiro você excluir a palavra "faltas", ou inserir 2 células, uma para o número 4 e outra para "faltas", pois para puxar o parâmetro de dias para condicionar sua fórmula, você precisa apenas do 4, mais uma vez o texto pode te atrapalhar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

entendo...

Eu pensei em mudar caracteres para valores numéricos, mas como trabalho em uma divisão, essa planilha irá servir para outras pessoas, mas se ao acaso eu não conseguir achar alguém que resolva isso, vou partir para essa opção kk

muito obrigado pela dica, abraços.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Faelstr07, veja se te ajuda:

 

Na célula K3 de sua planilha coloque a fórmula abaixo

 

=MÁXIMO(FREQÜÊNCIA(SE(C3:I3="F";COL(C3:I3));SE(C3:I3<>"F";COL(C3:I3))))

 

Depois de colar pressiona CTRL+SHIFT+ENTER, pois é uma fórmula matricial.

 

*EDIT: Esqueci do condicional

=SE(MÁXIMO(FREQÜÊNCIA(SE(C3:I3="F";COL(C3:I3));SE(C3:I3<>"F";COL(C3:I3))))=4;"Desligado";"Ligado")

Pressione CTRL+SHIFT+ENTER, pois é uma fórmula matricial.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu havia tentado mais cedo aquela primeira forma e tinha retornado o valor 4

Mas essa forma editada deu certo, e já vai me ajudar muito, mas tem um porém, eu queria automatizar o número de faltas, tipo: na célula G7, se eu mudar pra 5, a função iria contar agora 5 faltas consecutivas...

Você acha que tem alguma forma de fazer isso??

muito obrigado pela ajuda!

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Basta alterar no condicional:

 

=SE(MÁXIMO(FREQÜÊNCIA(SE(C3:I3="F";COL(C3:I3));SE(C3:I3<>"F";COL(C3:I3))))>=$G$7;"Desligado";"Ligado")

 

E na célula G7 preenche apenas com o número de faltas para ser desligado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, jpnb95 disse:

Basta alterar no condicional:

 

=SE(MÁXIMO(FREQÜÊNCIA(SE(C3:I3="F";COL(C3:I3));SE(C3:I3<>"F";COL(C3:I3))))>=$G$7;"Desligado";"Ligado")

 

E na célula G7 preenche apenas com o número de faltas para ser desligado.

dessa forma não está dando certo...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu tinha esquecido que era matricial kkk, desculpas..

Deu certo cara, muito obrigado mesmo! me ajudou muito..

 

adicionado 0 minutos depois

Aliás, salvou meu dia kk

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por nada, só não esquece de fixar a G7 igual ta na parte em vermelha da fórmula (>=$G$7)

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@jpnb95 Cara, eu te agradeço muito pela a ajuda, mas estou com outra dúvida, eu queria saber se nessa função que você fez, daria para adicionar mais um critério??

tipo: O novo critério seria um valor de faltas alternadas, por exemplo, se eu definisse esse novo critério como 8 faltas, quando fossem colocados 8 F's, não necessariamente consecutivos, a função também mostraria desligado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Faelstr07, basta usar Se(OU..., para satisfazer as condições:

 

Na célula G8 preencha com a quantidade de faltas totais que o aluno deve ter para ser desligado.


 

=SE(OU(MÁXIMO(FREQÜÊNCIA(SE(C3:I3="F";COL(C3:I3));SE(C3:I3<>"F";COL(C3:I3))))>=$G$7;CONT.SE(C3:I3;"F")>=$G$8);"Desligado";"Ligado")

 

Segue em anexo...

 

plan_JP.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×