Ir ao conteúdo
  • Cadastre-se
annabanana

VisualG 7 Faça o pseudocódigo para calcular o determinante de uma matriz 2 X 2 digitada

Recommended Posts

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/09/2018
// Seção de Declarações 
var
matriz: vetor [1..2,1..2] de real
//contadores
x,y: inteiro

inicio
// Seção de Comandos 
//Contador das Linhas
para x de 1 ate 2 faca
//contador das colunas
para y de 1 ate 2 faca
escreva("Digite o valor da Linha ",x, " Coluna ", y,":")
leia(matriz[x,y])
fimpara
escreval ("xxxxxxxxxxxxxxxxxx")
fimpara
//Mostrar valores da matriz
escreval ("valores da matriz")
escreval ("| ", matriz[1,1]," ",matriz[1,2],"|")
escreval ("| ", matriz[2,1]," ",matriz[2,2],"|")
//calcula o valor da determinante
determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])
escreval("O valor da determinante é:",determinante)
fimalgoritmo

Está dando erro na hora de achar a determinante, mas não consegui identificar.

determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
10 horas atrás, annabanana disse:

Está dando erro na hora de achar a determinante, mas não consegui identificar.

determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])

 

Analise o erro informado no Visualg!

 

Solução:

Spoiler

Vá lá e olha o erro!!!!

 

adicionado 12 minutos depois

Adendos:

 

1#

Sempre mantenha o código indentado, ex.:

algoritmo "FCdH"
var
   matriz: vetor [1..2,1..2] de real
   x,y: inteiro
inicio
para x de 1 ate 2 faca //Contador das Linhas
   para y de 1 ate 2 faca //contador das colunas
      {escreva("Digite o valor da Linha ",x, " Coluna ", y,":")} //ajuste nos espaçamentos
      escreva("Digite o valor da Linha",x," Coluna",y,": ")
      leia(matriz[x,y])
   fimPara
   escreval("xxxxxxxxxxxxxxxxxx")
fimPara

//Mostrar valores da matriz
escreval ("Valores da matriz")
escreval ("| ", matriz[1,1]," ",matriz[1,2],"|")
escreval ("| ", matriz[2,1]," ",matriz[2,2],"|")

//calcula o valor da determinante
determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])
escreval("O valor da determinante é:",determinante)
fimalgoritmo

 

 

 

2#

Em relação aos nomes das variáveis, talvez ficaria melhor utilizar i e j, já que para matrizes utilizam aij.

 

 

 

***
 

No aguardo.

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então... na segunda linha está dizendo: "Variável 'DETERMINANTE' não foi encontrada".

 

Está utilizando uma variável que não existe. Declare-a.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, annabanana disse:

Mas eu quero acha-la.

 

Mas o Visualg não sabe de disso. O programa apenas usa variáveis e faz processamentos... "interpretar que esse valor será uma determinante" é uma abstração do programador. Veja:

 

11 horas atrás, annabanana disse:

Está dando erro na hora de achar a determinante, mas não consegui identificar.


determinante <-(matriz[1,1]*matriz[2,2]-matriz[1,2]*matriz[2,1])

 

O comando <- serve para "atribuir o valor que está na direito dele, no algo que está na esquerda". Do lado direito, tem uma expressão com duas multiplicações e uma subtração e tal... O Visual apenas vai pegar o valor que está nos matriz[i,j]  e fazer as "contas". Após, vai atribuir o valor resultante no que está no lado esquerdo. Lá ele tenta identificar o que é determinante e simplesmente diz que não encontrou. (pois ela não existe).

 

Se quer utilizar uma variável para armazenar um valor, precisa declarar ela antes.

 

RESUMINDO:

Apenas declare a variável determinante lá no var. Como a matriz é de reais, determinante também deve ser do tipo real.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×