Ir ao conteúdo
  • Cadastre-se
Higor Gustavo Martins

VisualG Melhor e Pior Aluno, e a Maior e a Menor nota.

Recommended Posts

Como eu faço para aparecer o Nome  do meu 1° aluno quando eu colocar ele tanto como a melhor nota quanto a pior ?

 

Se eu colocar na 2° ou na 3° nota como o pior ou o melhor o nome aparece mas no 1° não...  

 

algoritmo "Melhoraluno"
var
   N, Contador: inteiro
   N1, maiorNota, menorNota: Real
   Aluno, MelhorAluno, piorAluno: caracter
inicio
      Escreval("---------------")
      Escreval(" Maradona louco ")
      Escreval("---------------")
      Escreva("Quantos alunos tem a turma: ")
      Leia(N)
      Contador <- 1
      Enquanto (Contador <= N) Faca
      Escreval("---------------")
              Escreval("Aluno ", Contador)
              Escreva("Nome do Aluno: ")
              Leia(Aluno)
              Escreva("Nota de ", Aluno, ": ")
              Leia(N1)
              se (contador = 1) entao
                maiorNota := N1
                menorNota := N1
              Senao
                   Se (contador = 1) entao
                      MelhorAluno:= Aluno
                      piorAluno:= Aluno
                   Fimse
                Se (N1 > maiorNota)entao
                   maiorNota <- N1
                   MelhorAluno <- Aluno
                Senao
                   Se (N1 < menorNota)entao
                     menorNota <- N1
                     piorAluno <- Aluno
                   Fimse
                Fimse
              Fimse
              Contador <- Contador + 1
      FimEnquanto
      Escreval("--------------------")
      Escreval("O melhor aproveitamento foi de ", MelhorAluno, " com a nota de ", maiorNota:3:1)
      Escreva("O pior aproveitamento foi de ", piorAluno, " com a nota de ", menorNota:3:1)
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@devair1010

 

Consegue me ajudar nesse problema ? 

porque eu ja fiz de tudo kkk e não sei aonde eu estou errando.... 

algoritmo "Melhoraluno"
var
   N, Contador: inteiro
   N1, maiorNota, menorNota: Real
   Aluno, MelhorAluno, piorAluno: caracter
inicio
      Escreval("---------------")
      Escreval(" Maradona louco ")
      Escreval("---------------")
      Escreva("Quantos alunos tem a turma: ")
      Leia(N)
      Contador <- 1
      Enquanto (Contador <= N) Faca
      Escreval("---------------")
              Escreval("Aluno ", Contador)
              Escreva("Nome do Aluno: ")
              Leia(Aluno)
              Escreva("Nota de ", Aluno, ": ")
              Leia(N1)
              se (contador = 1) entao
                maiorNota := N1
                menorNota := N1
              Senao
                   Se (contador = 1) entao
                      MelhorAluno:= Aluno
                      piorAluno:= Aluno
                   Fimse
                Se (N1 > maiorNota)entao
                   maiorNota <- N1
                   MelhorAluno <- Aluno
                Senao
                   Se (N1 < menorNota)entao
                     menorNota <- N1
                     piorAluno <- Aluno
                   Fimse
                Fimse
              Fimse
              Contador <- Contador + 1
      FimEnquanto
      Escreval("--------------------")
      Escreval("O melhor aproveitamento foi de ", MelhorAluno, " com a nota de ", maiorNota:3:1)
      Escreva("O pior aproveitamento foi de ", piorAluno, " com a nota de ", menorNota:3:1)
fimalgoritmo

 

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Higor Gustavo Martins     seu codigo esta bom .  mas ali depois do primeiro senao esse primeiro if nao precisa  dele apenas copie as duas linhas que estão dentro dele e coloque em cima junto com maiornota e menornota .

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
algoritmo "Melhoraluno"
var
   N, Contador: inteiro
   N1, maiorNota, menorNota: Real
   Aluno, MelhorAluno, piorAluno: caracter
inicio
      Escreval("---------------")
      Escreval(" Maradona louco ")
      Escreval("---------------")
      Escreva("Quantos alunos tem a turma: ")
      Leia(N)
      Contador <- 1
      Enquanto (Contador <= N) Faca
      Escreval("---------------")
              Escreval("Aluno ", Contador)
              Escreva("Nome do Aluno: ")
              Leia(Aluno)
              Escreva("Nota de ", Aluno, ": ")
              Leia(N1)
              se (contador = 1) entao
                maiorNota := N1
                menorNota := N1
                MelhorAluno:= Aluno
                piorAluno:= Aluno
                Se (N1 > maiorNota)entao
                   maiorNota <- N1
                   MelhorAluno <- Aluno
                Senao
                   Se (N1 < menorNota)entao
                     menorNota <- N1
                     piorAluno <- Aluno
                   Fimse
                Fimse
              Fimse
              Contador <- Contador + 1
      FimEnquanto
      Escreval("--------------------")
      Escreval("O melhor aproveitamento foi de ", MelhorAluno, " com a nota de ", maiorNota:3:1)
      Escreva("O pior aproveitamento foi de ", piorAluno, " com a nota de ", menorNota:3:1)
fimalgoritmo

@devair1010

 

Então eu fiz o que você disse e quando eu termino o programa ele me mostra o mesmo nome 2 vezes como MelhorAluno e como PiorAluno.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

@Higor Gustavo Martins, segue algumas dicas:
 

1) use a versão 3.6.0.5 do Visualg. Consideramos a mais estável.
Link: https://baixe.net/download/4313/visualg/

(se já usa, obviamente ignore essa dica)

 

2) Desative a "Tabulação inteligente". Basta ir no menu Manutenção/Configurações e desativa o recurso.

 

3) Sempre mantenha o código indentado. Para ajudar, pressione CTRL+G no Visualg. Depois é só manter a estrutura.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Que bom que encontrou a solução do problema, o pessoal daqui estão sempre a disposição.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×