Ir ao conteúdo
  • Cadastre-se
Usuario_HELP

Excel RESOLVIDO sequencia em valores repetidos

Recommended Posts

Boa noite, pessoal.

Estou com um problema e gostaria de uma ajudinha.

Tenho uma lista com valores repetidos, uso uma formula porém as vezes ela me deixa na mão.

Segue um exemplo 

COLUNA A = Formula da sequencia

COLUNA B = Valor resultante da formula para usar de referencia

COLUNA C = Valores repetidos na coluna, porém são codigos que estão relacionados a informações diversas.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 1
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 1
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 1
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 1
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 2
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 2
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 2
=SE(DESLOC(A2;0;3)=DESLOC(A2;-1;3);DESLOC(A2;-1;0)+1;1)  |||  =A2&"-"&C2  ||| 2


1 || 1 - 1 || 1
2 || 2 - 1 || 1
3 || 3 - 1 || 1

4 || 4 - 1 || 1

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

De forma que crie uma chave de pesquisa para cada celula repetida.

Se houver opções para essa situação, agradeço a atenção.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite @Usuario_HELP

 

Dúvida de Excel, sem anexar uma planilha de exemplo,demonstrando manualmente o resultado esperado, fica difícil obter ajuda.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Usuario_HELP , Bom Dia.

 

Usa esta formula confere

 

=CONT.SE($D$4:D4;D4)&"-"&D4

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda
 

Decio

 

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×