Ir ao conteúdo
  • Cadastre-se
cliffpk

Excel Arredondar data para dia 15 do mês

Recommended Posts

Pessoal, bom dia.

Preciso encontrar uma forma de arredondar uma data inserida em uma célula para o dia 15 do mês que aquela data foi inserida e caso a data seja menor que dia 15, retorne na célula com a fórmula o dia 15 do mês anterior.

Por exemplo,

Na célula A1 insere-se 22/05/2018, a data mostrada na célula A2 seria 15/05/2018. 

Caso fosse inserido 03/09/2018, retornaria em A2 o valor do dia 15/08/2018.

Caso fosse inserido 14/09/2018, retornaria em A2 o valor do dia 15/08/2018.

Alguem sabe me dizer se é possível e como é possível? Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia @cliffpk

 

Copie e cole em A2 a formula abaixo:

=SE(DIA(A1)<15;DATA(ANO(A1);MÊS(A1)-1;15);DATA(ANO(A1);MÊS(A1);15))

Não se esqueça de clicar em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se a data arredondada puder ser colocada em outra coluna, cole a fórmula abaixo em B1, por exemplo, e arraste para baixo.

Em seguida você poderá copiar o intervalo com as fórmulas e colar como Valores sobrepondo as datas da coluna A.

No entanto, se você quer arredondar as datas na própria coluna A, então a solução será via macro.

=DATA(ANO(A1);MÊS(A1)-(DIA(A1)<15);15)

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Muito obrigado @Patropi, funcionou perfeitamente.

Obrigado também Osvaldomp mas não será necessário!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×