Ir ao conteúdo
  • Cadastre-se
Chjorge

Excel RESOLVIDO Manter Intervalo na fórmula EXCEL

Recommended Posts

Tenho uma planilha em Excel, criei uma tabela com a ferramenta de Tabela do Excel.

Quando insiro nova linha utilizando a tecla TAB, a nova linha carrega a fórmula que tenho em uma célula --> =PROCV(Plan1!E9;Plan2!A1:B7;2;0) <--, porém a fórmula é atualizada sem manter o intervalo da função PROCV.

 

Na nova linha a fórmula passa a ser =PROCV(Plan1!E9;Plan2!A2:B8;2;0) e eu preciso manter sempre A1:B7. E além disso, onde está E9, aí sim preciso que atualize para E10 e assim por diante.

 

O que devo fazer?

print excel 2.PNG

print excel.PNG

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde @Chjorge

 

Tem que travar o intervalo utilizando cifrões, ficando assim:

=PROCV(Plan1!E9;Plan2!$A$1:$B$7;2;0)

Se foi útil, clique em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
23 horas atrás, Patropi disse:

Boa tarde @Chjorge

 

Tem que travar o intervalo utilizando cifrões, ficando assim:


=PROCV(Plan1!E9;Plan2!$A$1:$B$7;2;0)

Se foi útil, clique em Curtir.

 

[]s

Obrigado pela ajuda, mas preciso que fique sempre A1:B7 (não pode mudar para A2:B8.

Colocando o $, está mantendo as colunas, mas alterando as linhas.

 

Alguma outra sugestão?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Chjorge

 

Se você fizer corretamente vai bloquear colunas e linhas, mas se você colocar apenas um cifrão vai bloquear só a coluna ou só a linha, dependendo de onde você colocar.

 

O meu exemplo está correto, preste atenção!

 

Não se esqueça de clicar em Curtir nas minhas respostas

 

[]s

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 19/10/2018 às 17:25, Patropi disse:

@Chjorge

 

Se você fizer corretamente vai bloquear colunas e linhas, mas se você colocar apenas um cifrão vai bloquear só a coluna ou só a linha, dependendo de onde você colocar.

 

O meu exemplo está correto, preste atenção!

 

Não se esqueça de clicar em Curtir nas minhas respostas

 

[]s

Eu tinha copiado a sua fórmula e colado na célula, então não tinha como eu errar, mas percebi que as opções de cálculo estavam como MANUAL, por isso eu não percebia que a solução tinha funcionado.

 

Alterei para calculo automático!

 

Obrigado pela ajuda.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×