Ir ao conteúdo
  • Cadastre-se
Rodrigo Luis Mendes

Excel RESOLVIDO Comparar colunas para localizar itens faltantes

Recommended Posts

Olá galera, boa tarde.

Estou com um desafio e gostaria de pedir a ajuda de vocês.

Na primeira tabela existem 245 itens a mais que na segunda (identifiquei simplesmente pela contagem de itens) e eu precisaria encontra-los.

O desafio existe pois existem itens duplicados que devem ficar na tabela, ou seja, preciso localizar os 245 itens a mais sem retirar os duplicados.

Consegui usando algumas fórmulas encontrar 229, outra vez 233 e mais uma tentativa 235 mas não cheguei aos 245.

 

Poderiam me ajudar ?
Tentei anear a planilha aqui mas o arquivo é maior que 4,88mb, portanto estou colocando uma imagem.

Clube.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Qual o critério para manter as células duplicadas? Favor especificar como seriam os filtros para facilitar na resolução.

Se possível, anexe uma amostra da sua planilha com o resultado desejado ou, compacte o arquivo e anexe.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Henrique.

Preciso identificar exatamente quais são os 245 itens que constam na tabela maior.

O desafio existe por conta dos duplicados.

Ex:

 Tabela 1                             Tabela 2

     A                                         C

     B                                         A

     C                                         F

     D                                         B

     A

Eu preciso identificar que tem 1 item a mais na tabela 1.

Porém, na tabela 1 podem existir valores duplicados (A) e que eu não consigo identificar proque ele busca na tabela 2 e a formula encontra. Daí, mesmo tento só 1 "A" na tabela 2 e 2 "As" na tabela 1 a fórmula marca os "As" da tabela 1 como localizados.

Agora imagina isso em mais de 3.000 itens...

 

O que eu fiz até agora foi usar a fórmula =SE(ÉERROS(CORRESP(X;X:X;0));"";"CONFERE").

Daí eu apliquei filtro dos itens que não tem referência mas só encontrei 233. Coloquei a imagem também para facilitar o entendimento.

 

Vou anexar a tabela compactada para tentar facilitar.

 

Obrigado pela ajuda

Clube Hardware.7z

Clube.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia @Rodrigo Luis Mendes

 

A formula abaixo retorna os valores únicos, veja se te atende.

=SE(ÉERROS(PROCV(K3;$C$3:$C$3636;1;0));K3;"")

Dê retorno.

 

Não se esqueça de clicar em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi não sei se fiz algo errado mas não funcionou.

 

Apliquei a fórmula nas 2 tabelas para testar mas a maior parte dela fica em branco.

Segue imagem da tabela. Ajustei a fórmula conforme as colunas comparadas.

 

E mais uma vez, obrigado pela ajuda.

 

Clube 2.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi @lHenrique_10  agradeço a ajuda de vocês.

 

Usei a sua fórmula @Patropi  mas inverti o final dela.

Daí consegui localizar os itens que não tinham correspondentes.

Dai reduziu a lista e consegui fechar usando uma condicional.

 

Me ajudaram bastante.

Obrigado.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×