Ir ao conteúdo
  • Cadastre-se
DeathDark

Erro ao tentar alterar DNS - Windows 10

Recommended Posts

Eu removo o dns, clico em OK e na próxima janela quando vou clicar em OK ele da essa mensagem:

 

"Ocorreu uma condição inesperada. Nem todas as alterações em configurações solicitadas puderam ser feitas."

 

959224087_Semttulo.png.2033810411bec4baa8a7c0e169f5d022.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não se remove os DNS manualmente, é só marcar 'Obter o endereço dos servidores DNS automaticamente' e pressionar OK
O sistema irá tirá-los automaticamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Abra uma janela do Prompt de Comando (Admin) e execute os comandos abaixo um a um:

 

CHKDSK /R
SFC /SCANNOW
DISM /Online /Cleanup-image /Restorehealth

 

Ao final veja se resolve.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente via comando, abra o cmd como Administrador

Listar as interfaces no pc:
netsh interface ip show interfaces

 

Resultado deverá ser este:

Índ     Met         MTU          Estado                Nome
---  ----------  ----------  ------------  ---------------------------
  1          75  4294967295  connected     Loopback Pseudo-Interface 1
  4          35        1500  connected     Ethernet
  
No comando seguinte use o número do indéx mostrado acima

Definir busca de endereços dns automática:
netsh interface ip set dns 4 dhcp

Compartilhar este post


Link para o post
Compartilhar em outros sites
Citação
2 horas atrás, f_neto disse:

Tente via comando, abra o cmd como Administrador

Listar as interfaces no pc:
netsh interface ip show interfaces

 

Resultado deverá ser este:

Índ     Met         MTU          Estado                Nome
---  ----------  ----------  ------------  ---------------------------
  1          75  4294967295  connected     Loopback Pseudo-Interface 1
  4          35        1500  connected     Ethernet
  
No comando seguinte use o número do indéx mostrado acima

Definir busca de endereços dns automática:
netsh interface ip set dns 4 dhcp

 

Deu mensagem "Elemento não encontrado." após digitar o "netsh interface ip set dns 6 dhcp"

Do ciro-mota fiz o procedimento e nada mudou.

Eu creio que isso começou após eu instalar o linux através do VMware.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

O VMWare cria adaptadores de rede

Talvez esteja selecionando o adaptador errado

O normal é ele se chamar Ethernet

 

Coloque aqui uma imagem dos seus adaptadores de rede

 

Também pode dar uma olhada via cmd nos adaptadores com o comando específico do ipv4

netsh interface ipv4 show config

 

Outra maneira para colocar dns automático específico no ipv4

netsh interface ipv4 set address name="Ethernet" dhcp 

Compartilhar este post


Link para o post
Compartilhar em outros sites
39 minutos atrás, f_neto disse:

O VMWare cria adaptadores de rede

Talvez esteja selecionando o adaptador errado

O normal é ele se chamar Ethernet

 

Coloque aqui uma imagem dos seus adaptadores de rede

 

Também pode dar uma olhada via cmd nos adaptadores com o comando específico do ipv4

netsh interface ipv4 show config

 

Outra maneira para colocar dns automático específico no ipv4

netsh interface ipv4 set address name="Ethernet" dhcp 

 

Eu imaginei que seria isso e já tinha desabilitado a conexão do vmware.

 

Referente ao comando do dhcp ele diz "O DHCP já está habilitado nesta interface."

A minha conexão está fixada com o dns do google e mesmo se eu tento alterar para aquele 1.1.1.1 ou até mesmo deixar em automatico, ele da aquela mensagem que postei anteriormente.

Sem título.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Talvez um flushdns ajude, se não der certo acho que vai ter que ser na força bruta, ou seja, desinstalar o drive ou até mesmo excluir este adaptador e reiniciar, acho que o próprio Windows vai se arrumar

 

Abra o cmd como Admin e digite

 

ipconfig /release
ipconfig /flushdns
ipconfig /renewnetsh int
ipconfig /renew
netsh int ip set dns
netsh winsock reset

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não é necessário manter os adaptadores da WMware desabilitados, pode habilitar normalmente os dois.

 

Poste uma imagem em tela inteira (como a de cima), das propriedades que quer alterar.

Compartilhar este post


Link para o post
Compartilhar em outros sites
18 horas atrás, f_neto disse:

Talvez um flushdns ajude, se não der certo acho que vai ter que ser na força bruta, ou seja, desinstalar o drive ou até mesmo excluir este adaptador e reiniciar, acho que o próprio Windows vai se arrumar

 

Abra o cmd como Admin e digite

 

ipconfig /release
ipconfig /flushdns
ipconfig /renewnetsh int
ipconfig /renew
netsh int ip set dns
netsh winsock reset

 

Os comandos não funcionaram.

 

27 minutos atrás, ciro-mota disse:

Não é necessário manter os adaptadores da WMware desabilitados, pode habilitar normalmente os dois.

 

Poste uma imagem em tela inteira (como a de cima), das propriedades que quer alterar.

 

Eu coloco para obter dns automaticamente e dou o OK. Aí quando vou dar o segundo OK, ele da a mensagem do primeiro post.

Sem título.png

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, DeathDark disse:

Eu coloco para obter dns automaticamente e dou o OK. Aí quando vou dar o segundo OK, ele da a mensagem do primeiro post.

Não sei se foi erro de digitação, mas não tem o segundo OK

Fiz um teste e após colocar o DNS do Google pressionei OK e na próxima janela tem o botão de Fechar.

Refiz o teste colocando em automático e pressionei OK e na próxima janela tem o botão de Fechar

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 minutos atrás, f_neto disse:

Não sei se foi erro de digitação, mas não tem o segundo OK

Fiz um teste e após colocar o DNS do Google pressionei OK e na próxima janela tem o botão de Fechar.

Refiz o teste colocando em automático e pressionei OK e na próxima janela tem o botão de Fechar

 

 

Da uma olhada no print que postei anteriormente, tem o primeiro OK, coloca o DNS e o segundo que é a janela que está atras.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, quando eu tenho as duas janelas aparece os dois OK

Mas quando pressione o OK da alteração ela fecha e a janela de trás muda para o botão Fechar

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
agora, ciro-mota disse:

Ative os adaptadores da VWware antes da modificação.

 

Eles estão ativados, tanto faz eles ativados ou desativados, a mensagem é a mesma. Não estou em casa agora,  a noite vou reinstalar o driver e posto para ver se resolveu.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Abra uma janela do Prompt de Comando (Admin) e execute o comando abaixo:

 

netcfg –d

 

Isso deverá desinstalar os adaptadores, reinicie o PC e tente reinstala-los. Veja se resolve.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 25/10/2018 às 15:44, ciro-mota disse:

Abra uma janela do Prompt de Comando (Admin) e execute o comando abaixo:

 

netcfg –d

 

Isso deverá desinstalar os adaptadores, reinicie o PC e tente reinstala-los. Veja se resolve.

O comando não funcionou, mas igual eu desinstalei o driver e não consegui instalar o driver novamente. Eu faço a instalação e nada acontece, eu fico sem internet. Tive que fazer a restauração do sistema para a internet voltar a funcionar.
Minha placa-mãe é PRIME B350M-A, fiz download direto do site https://www.asus.com/us/Motherboards/PRIME-B350M-A/HelpDesk_Download/

A conexão na barra de tarefas fica com um X e quando vou na conexões de rede não aparece nenhuma conexão, apenas as do VMware.

 

EDIT:

Eu esqueci de rodar o cmd como administrador, feito isso fiz a desinstalação, porém não consigo instalar o drive.

Pelo setup da esse erro:526859735_Semttulo.thumb.png.cf0a0b09129be970e69a075d525fb2d3.png

 

E manual pelo gerenciador de dispositivos da esse erro:

1414121754_Semttulo2.thumb.png.6e65f650ab6574848734e3d78532c78a.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não precisa executar o driver baixado, deixe que o Windows instale o próprio driver. Desinstale novamente pelo Gerenciador de Dispositivos, reinicie e reinstale por lá novamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 horas atrás, ciro-mota disse:

Não precisa executar o driver baixado, deixe que o Windows instale o próprio driver. Desinstale novamente pelo Gerenciador de Dispositivos, reinicie e reinstale por lá novamente.

 

Não adiantou.

Eu desinstalo e ele some da lista, aí eu reinicio o PC e ele fica desse jeito:
1559246330_Semttulo3.thumb.png.180bbe185a4fce994fcc97a53a27f05d.png

 

Eu clico para atualizar o driver e da a seguinte mensagem.

 

192745156_Semttulo4.thumb.png.61f20cc3a40218425a596c025dcf3a3a.png

 

Edit:

Pelo comando "netsh interface ipv4 set dnsservers name="Ethernet" dhcp" eu consegui mudar o dns.

Compartilhar este post


Link para o post
Compartilhar em outros sites
20 horas atrás, DeathDark disse:

Edit:

Pelo comando "netsh interface ipv4 set dnsservers name="Ethernet" dhcp" eu consegui mudar o dns.

 

O problema foi resolvido?

Compartilhar este post


Link para o post
Compartilhar em outros sites
agora, ciro-mota disse:

 

O problema foi resolvido?

 

Foi e não foi.. rs.

Manualmente eu não consigo alterar, ele continua dando aquele erro, mas pelo comando funciona.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ciro-mota

Não estou em casa agora, mas ontem a noite eu percebi que ficava dando aquele som de como você tivesse colocado um pendrive ou algum dispositivo, sabe? O som que faz ao conectar um dispositivo no computador. Porém, ele dava o som e eu ia olhar na  barra de tarefas para ver o que é, mas ele sumia e depois fazia o som de novo, ficou assim um tempo.

Crio um tópico novo ou será que isso pode ser parte do problema que estou tendo?

A noite tento gravar um vídeo para mostrar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×