Ir ao conteúdo
  • Cadastre-se
lucianopach

Excel RESOLVIDO Separação de dados contidos em uma célula

Recommended Posts

 

Se você quiser experimentar uma solução via UDF, instale o código abaixo em um módulo comum, assim:

1. copie o código daqui
2. a partir da planilha em que estão os dados tecle 'Alt+F11' para acessar o editor de VBA
3. no menu do editor >> Inserir >> Módulo
4. cole o código na janela em branco que vai se abrir
5. feito! 'Alt+Q' para retornar para a planilha

6. na célula B2 cole ~~~> =desmemb($A2) / arraste até E2 / em seguida arraste a seleção para baixo

Function Desmemb(c As Range)
 Dim m As Long, v As Long, d As String
  m = InStr(c.Value, "-"): v = InStrRev(c.Value, "/")
  Select Case Application.Caller.Column
   Case 2: Desmemb = Left(c.Value, 3)
   Case 3
    If m = 0 Then Desmemb = "" Else Desmemb = Mid(c.Value, 5, 3)
   Case 4
    If m = 0 Then Desmemb = Mid(c.Value, 5, 5) Else Desmemb = Mid(c.Value, 9, 5)
   Case 5
    If v = 10 Then
     Desmemb = Mid(c.Value, 11, 5)
    ElseIf m > 0 Then
     Desmemb = Mid(c.Value, 15, 5)
    Else: Desmemb = Mid(c.Value, 28, 5)
    End If
  End Select
End Function

 

Ou, solução por fórmulas:

em B2 ~~~> =ESQUERDA(A2;3)
em C2 ~~~> =SE(NÚM.CARACT(A2)<=21;EXT.TEXTO(A2;5;3);"")
em D2 ~~~> =EXT.TEXTO(A2;LOCALIZAR("(";A2)+1;5)
em E2 ~~~> =SE(NÚM.CARACT(A2)<=18;EXT.TEXTO(A2;11;5);SE(NÚM.CARACT(A2)<=21;EXT.TEXTO(A2;15;5);EXT.TEXTO(A2;28;5)))

 

Em seguida arraste B2:E2 para baixo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, deciog disse:

@lucianopach , Bom Dia.

 

Segue por formulas

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda
 

Decio

 

horários Decio.xlsx

Bom dia Decio!

 

Obrigado pela resposta e ajuda. Só gostaria que na célula B4 aparecesse só "Ter", B5 "Seg" e B7 só "Qua".

 

Obrigado

 

Luciano

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×