Ir ao conteúdo
  • Cadastre-se
Gamerulew

VisualG Visualg 3.0 não roda escolha

Recommended Posts

Quando tento rodar um algoritmo que contem "escolha" no visualg 3.0 ele simplesmente pula esse escolha e ignora o caso. O que eu faço para corrigir esse erro?

No algoritmo abaixo mesmo que eu digite a palavra a que o caso se refere o programa ira pular para o "outrocaso" e escreverá o conteudo presente nele.

 

EX:

<algoritmo "semnome"
var
   cont:inteiro
   modelo,outro:caracter
inicio
   escreva("entre com o modelo do calçado:")
   leia(modelo)
   escolha modelo
   caso "mocassim"
      escreval("o modelo do calçado é masculino.")
   caso "rasteirinha"
      escreval("o modelo do calçado é feminino.")
   outrocaso
      escreval("o calçado é infantil.")
   fimescolha
fimalgoritmo>

 

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aqui funcionou po, rodou de boa. Tenta reinstalar o Visualg pra ver se vai: Baixar Visualg 3.0.7

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×