Ir ao conteúdo
  • Cadastre-se
Exymus

Excel RESOLVIDO Comparar dados em duas colunas

Recommended Posts

Boa tarde pessoal! Tenho uma planilha com duas colunas. Gostaria de comparar os nomes da coluna A com a coluna B, e os que não forem correspondentes em B de A sejam coloridos. Tentei com a função ISERROR (MATCH(A2,$C$2:$C$14,0)) mas não obtive resultado. Essa função só funciona com números ou nomes também? Por que nas colunas só tem nomes. Desde já muito obrigado! 

TAF.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@PauloFagoto Sim, inclusive gostaria de saber se a fórmula que citei ai em cima funciona pra nomes, pois não deu certo aqui. É bem simples, só quero destacar os nomes que estão numa coluna e na outra não ou vice versa. O importante é destacar os que não estão.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Exymus

 

O problema é que os nomes da coluna F possuem um espaço em branco na frente, e o Excel considera como outro carácter, portanto não é igual.;

 

Para testar coloque o cursor na célula F3 em frente ao Neto e olhe na barra de formula que você irá ver o espaço.

 

Se foi útil, clique em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi Boa tarde! Então, eu pensei nisso também. Só que ai usei a fórmula =arrumar pra tirar os espaços e mesmo assim continuo sem resultado. Eu nunca usei essa fórmula em letras ai não sabia se funcionava. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Exymus

 

Aplique a função arrumar em outra coluna --> depois copie e cole somente valores na coluna F ---> experimnete utilizar a fórmula abaixo na formatação condicional:

=CONT.SE($F$2:$F$1500;A2)=0

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi Deu certo! Mas apareceu menos valores do que eu imaginava. Vou revisar a planilha para ver se esta faltando algo. Muito obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Exymus

 

Pintei de laranja o que tem em B e não em A confere

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda
 

Decio

 

TAF.xlsx

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×