Ir ao conteúdo
  • Cadastre-se
Irwing Seiji Ato

VisualG Programação Vetores Visualg somente esse que não consegui fazerf

Recommended Posts

Criar um algoritmo que lê um vetor de 10 posições e o escreve. Substituir todos os valores nulos desse vetor por 1 e escrevê-lo novamente

 

Não consigo fazer com que leiam e substitua os vetores como se faz?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tentei fazer o exercício porém não consigo fazer a parte de substituir números nulos por 0

olhem o código 

Var
   // Seção de Declarações das variáveis
   n: vetor [1..10] de inteiro
   substituto: vetor [1..10] de inteiro
   c:inteiro
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
para c de 1 ate 10 faca
   leia (n[c])
fimpara
para c de 1 ate 10 faca
   se (n[c] > 0) entao
      substituto[c]<-n[c]
   fimse
fimpara
para i de 1 ate 10 faca
   escreva (substituto[c])
fimpara
fimalgoritmo

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Irwing Seiji Ato    os valores nulos são os zeros que estiverem no vetor , então depois de pegar os números e colocar no vetor , use um laço de repetição para para  imprimir esses números e dentro desse mesmo laço já faz as comparações para ver se algum desses números são nulos (  zero  )  e se for então coloca o número  1  no vetor nessa mesma posição , e depois que sair desse laço coloque outro para para imprimir o vetor novamente e dessa vez imprimirá com os  números zeros substituídos pelo número  1  ,  então seu código pode ser assim  :

Algoritmo "substituir vetor"
Var
  n         : vetor [1..10] de inteiro
  substituto: vetor [1..10] de inteiro
  c,i       :                  inteiro
Inicio
  escreval("preencher o vetor com dez números")
  para c de 1 ate 10 faca
    escreva(c,"º número ")
    leia( n[c] )
  fimpara
  escreval
  escreval("os dez números no vetor")
  para c de 1 ate 10 faca
    escreva( n[c] )
    se  n[c] = 0  entao
      n[c] <- 1
    fimse
  fimpara
  escreval
  escreval
  para i de 1 ate 10 faca
    escreva( n[i] )
  fimpara
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×