Ir ao conteúdo
  • Cadastre-se
MasterDaron

VisualG Fluxograma de um Algoritmo de Calculo de Média?

Recommended Posts

Galera gostaria por favor da ajuda de vocês aqui da comunidade, estou precisando fazer um fluxograma sobre esse algoritmo mais não sei por onde começar desde já agradeço a colaboração de todos!!!
 

algoritmo "calculo_media"
// Função: calcular a média
var
i:inteiro
nota,media,somanota:real

inicio
// receba quatro notas de provas, calcule e caso:
// entre 7 e 10 aluno aprovado
// caso entre 5 e 7 aluno em recuperação.
// caso entre 0 e 5 aluno reprovado
repita
      i<-i+1 // contagem
      escreva("Digite a ",i," nota:")
      leia(nota)
      escolha nota
             caso 0 ate 10
                  somanota<-somanota+nota
             outrocaso
                      i<-i-1
                      escreval("NOTA INVÁLIDA!")
                      escreval("DIGITE NOVAMENTE! NOTAS DE 0 A 10!")
             fimescolha
      // soma a nota atual com a anterior
ate i=4


media<-somanota/i
escreval("A média do aluno ")
escreval(" foi de: ",media," pontos")
escolha media
   caso 7 ate 10
      escreval("APROVADO")
   caso 5 ate 7
      escreval("RECUPERAÇÃO")
   caso 0 ate 5
      escreval("REPROVADO")
   outrocaso
fimescolha
fimalgoritmo

 

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MasterDaron      para comecar voce coloca um circulo ,  que por sinal tambem eh usado para finalizar o fluxograma , as tomadas de decisoes  use. Um losango ,    nas acoes  use retangulos  ,   nao posso fazer para voce pois eh contra as regras do forum , entao faca e poste aqui para vermos como esta e em que podemos ajudar.   .

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×