Ir ao conteúdo
  • Cadastre-se
rafaeddd

VisualG VISUAL G % comercial (Dificuldade)

Recommended Posts

o que eu conseguir foi dar o desconto porém so consigo para 10% os outros eu nao consigo fazer ... preciso de ajuda 

// EXERCICIO NUMERO 2
// Disciplina  : [Linguagem e Lógica de Programação]
// Professor   : Lourivaldo Pereira
// Aulo        : Rafael Santos Castilho
Algoritmo "Desconto para comercio"
Var
// Seção de Declarações das variáveis
descricaoproduto:caractere
precounitario,quantidade:real
precototal,valordesconto,valorpagar:real
valorpagardesconto:real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
          escreva("Descrição Do Produto..............: ")
          leia(descricaoproduto)
          escreva("Preço Unitario..................R$: ")
          leia(precounitario)
          escreva("Quantidade........................: ")
          leia(quantidade)
          
          precototal<-quantidade*precounitario //preço por unidade
          
          //OS DESCONTOS
          //15% menor R$150
          se precototal<150 entao
          valordesconto<-(precototal*15/100)
          senao
          valorpagar<-precototal
          fimse
          //18%  de R$150 a R$499
          se precototal>150 entao
          valordesconto<-(precototal*18/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal<499 entao
          valordesconto<-(precototal*18/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal>500 entao
          valordesconto<-(precototal*23/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal<799 entao
          valordesconto<-(precototal*23/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal>800 entao
          valordesconto<-(precototal*27/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal<=1000 entao
          valordesconto<-(precototal*27/100)
          senao
          valorpagar<-precototal
          fimse
          
          se precototal>1001 entao
          valordesconto<-(precototal*30/100)
          senao
          valorpagar<-precototal-valordesconto
          fimse

          escreval("Preço Total do Produto..........R$:  ",precototal)
          escreval("Valor do Desconto...............R$:  ",valordesconto)
          escreval("Valor a Pagar...................R$:  ",valorpagar)
          escreval("********FIM DO ALGORITMO*******")
 fimalgoritmo

 

Sem título.png

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@rafaeddd Olá. É o seguinte amigo: Não estou entendendo o por quê desse senao que você está usando nas condições do se

Quando existe um se/senao apenas um é executado, logo, no caso do preço ser maior do que 1000, o se é executado, e o senao não vai ser executado e, com isso, não vai ocorrer a subtração do preço total do produto pelo valor do desconto

Percebeu onde está o erro?

 

Qualquer dúvida é só perguntar, ok?

Também recomendo o uso de estruturas aninhadas, que, na Linguagem C, seria else if (se senao). Não sei como é isso no Visualg, tal como @Kauan Maia da Silva falou

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1109118406_Semttulo.png.a7cac34f92a240d309d2624cc6f785b0.png

 

acho que consegui 

 

Algoritmo "Desconto para comercio"
Var
// Seção de Declarações das variáveis
descricaoproduto:caractere
precounitario,quantidade:real
valordesconto,valorpagar:real
valorpagardesconto:real
precototal:real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
          escreva("Descrição Do Produto..............: ")
          leia(descricaoproduto)
          escreva("Preço Unitario..................R$: ")
          leia(precounitario)
          escreva("Quantidade........................: ")
          leia(quantidade)

          precototal<-quantidade*precounitario //preço por unidade

          //OS DESCONTOS
          //15% menor R$150
          caso precototal 0 ate 149
          valordesconto<-(precototal*15/100)
          caso precototal 150 ate 499 entao
          valordesconto<-(precototal*18/100)
          caso precototal 500 ate 799 entao
          valordesconto<-(precototal*23/100)
          caso precototal 800 ate 1000 entao
          valordesconto<-(precototal*27/100)
          caso precototal > 1000  entao
          valordesconto<-(precototal*30/100)
          fimescolha

          valorpagar<-precototal-valordesconto
          escreval("Preço Total do Produto..........R$:  ",precototal)
          escreval("Valor do Desconto...............R$:  ",valordesconto)
          escreval("Valor a Pagar...................R$:  ",valorpagar)
          escreval("********FIM DO ALGORITMO*******")
 fimalgoritmo

esta correto com o exercício ? 

adicionado 1 minuto depois

@giu_d sim, agora eu entendi como usar o senao retirei todos e mudei de se para caso ... 

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kauan Maia da Silva

4 minutos atrás, Kauan Maia da Silva disse:

@rafaeddd Ah sim

adicionado 3 minutos depois

O desconto está dando errado, pois eu digitei 100 e o desconto não ficou 15%, ficou com 30

sabe como faço para corrigir isto ? 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, Kauan Maia da Silva disse:

As estruturas condicionais aninhadas no visualg funciona assim:

 

Se (bloco A = Verdadeiro) então

    Escreval()

senao

    Se (Bloco B = Verdadeiro) então

          Escreval()

    senao

          Escreval()

    FimSe

FimSe

 

@Kauan Maia da Silva Obrigado! Não estava lembrando como era 😉

Comecei a estudar com o Visualg e fazia muito códigos para praticar. Fica a dica!  Vale muito a pena!

  • Curtir 2
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
59 minutos atrás, rafaeddd disse:

@Kauan Maia da Silva é possivel fazer este codigo de outra maneira para nao bugar ? 

Eu consegui utilizando estruturas condicionais aninhadas:

Algoritmo "Desconto para comercio"
Var
   // Seção de Declarações das variáveis
   descricaoproduto:caractere
   precounitario,quantidade:real
   valordesconto,valorpagar:real
   valorpagardesconto:real
   precototal:real

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   escreva("Descrição Do Produto..............: ")
   leia(descricaoproduto)
   escreva("Preço Unitario..................R$: ")
   leia(precounitario)
   escreva("Quantidade........................: ")
   leia(quantidade)

   precototal<-quantidade*precounitario //preço por unidade

   //OS DESCONTOS
   //15% menor R$150

   Se (precototal >= 0) e (precototal < 150) entao
      valordesconto<-(precototal*15/100)
   senao
        Se (precototal >= 150) e (precototal < 500) entao
           valordesconto<-(precototal*18/100)
        senao
             Se (precototal >= 500) e (precototal < 800) entao
                valordesconto<-(precototal*23/100)
             senao
                  Se (precototal >= 800) e (precototal < 1000) entao
                      valordesconto<-(precototal*27/100)
                  senao
                       Se (precototal >= 1000) entao
                          valordesconto<-(precototal*30/100)
   FimSe
        FimSe
             FimSe
                  FimSe
                       FimSe


   valorpagar<-precototal-valordesconto
   escreval("Preço Total do Produto..........R$:  ",precototal)
   escreval("Valor do Desconto...............R$:  ",valordesconto)
   escreval("Valor a Pagar...................R$:  ",valorpagar)
   escreval("********FIM DO ALGORITMO*******")
fimalgoritmo
adicionado 5 minutos depois

@rafaeddd Caso esteja com dúvidas, esse vídeo esclarece tudo ;) :

 

  • Obrigado 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kauan Maia da Silva MUITO OBRIGADO ! deu tudo certo agora ! 🤩

// EXERCICIO NUMERO 2
// Disciplina  : [Linguagem e Lógica de Programação]
// Professor   : Lourivaldo Pereira
// Aulo        : Rafael Santos Castilho
Algoritmo "Desconto para comercio"
Var
// Seção de Declarações das variáveis
descricaoproduto:caractere
precounitario,quantidade:real
valordesconto,valorpagar:real
valorpagardesconto:real
precototal:real
//
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
          escreva("Descrição Do Produto..............: ")
          leia(descricaoproduto)
          escreva("Preço Unitario..................R$: ")
          leia(precounitario)
          escreva("Quantidade........................: ")
          leia(quantidade)

          precototal<-quantidade*precounitario //preço por unidade

          //OS DESCONTOS
          Se (precototal >= 0) e (precototal < 150) entao
          valordesconto<-(precototal*15/100) //15%
          senao
          Se (precototal >= 150) e (precototal < 499.99) entao
          valordesconto<-(precototal*18/100) //18%
          senao
          Se (precototal >= 500) e (precototal < 799.99) entao
          valordesconto<-(precototal*23/100) //23%
          senao
          Se (precototal >= 800) e (precototal < 1000) entao
          valordesconto<-(precototal*27/100) //27%
          senao
          Se (precototal >= 1000) entao
          valordesconto<-(precototal*30/100) //30%
          FimSe
          FimSe
          FimSe
          FimSe
          FimSe

          valorpagar<-precototal-valordesconto
          escreval("Preço Total do Produto..........R$:  ",precototal)
          escreval("Valor do Desconto...............R$:  ",valordesconto)
          escreval("Valor a Pagar...................R$:  ",valorpagar)
          escreval("********FIM DO ALGORITMO*******")
 fimalgoritmo

 

adicionado 0 minutos depois
12 minutos atrás, giu_d disse:

 @rafaeddd Com respeito a estruturas aninhadas encontrei esse link:

https://dicasdeprogramacao.com.br/estrutura-de-selecao-multipla-escolha-caso/

adicionado 1 minuto depois

Comecei também a estudar com esse professor, o Gustavo rs...  

obrigado 

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

1#

49 minutos atrás, rafaeddd disse:

@Kauan Maia da Silva MUITO OBRIGADO ! deu tudo certo agora ! 🤩

 

Creio que ainda não... Veja o enunciado:

2 horas atrás, rafaeddd disse:

Sem título.png

 

No seu código você está verificando preço total, mas o que foi pedido foi para verificar do preço do produto (individual).
 

 

 

2#

Algumas faixas de descontos estão erradas. Experimente inserir por exemplo o preço 499,99.

 

 

 

3#

O exercício fala em "dar desconto de todos os produtos", ou seja, sugere que são várias produtos e que precisa dar esses descontos a eles.

 

Minha sugestão seria utilizar vetores para armazenar os dados do produtos. Após ler os produtos, exibe na tela o valor do produto (individual), a % de desconto que o produto vai ter e o seu novo valor com o desconto de cada um dos produtos.

 

 

 

***

 

No aguardo.

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×