Ir ao conteúdo
  • Cadastre-se
rafaeddd

VisualG Visual G Vetores (Didático)

Recommended Posts

Nao entendi como usar vetores 

1961147621_Semttulo.png.f19635a6d561cfc0bffebdde24e0e5c9.png

// EXERCICIO NUMERO 7
// Disciplina  : [Linguagem e Lógica de Programação]
// Professor   : Lourivaldo Pereira
// Aulo        : Rafael Santos Castilho

Algoritmo "7"
var
 Q: vetor[1..10] de inteiro
 i,posicao: inteiro
inicio

 para i de 1 ate 10 faca
            escreval("Digite o", i, "º numero:")
            leia(Q[i])
            posicao <- i
            escreval("Na posição:", posicao)
            escreval
            enquanto (Q[i] < 0) faca
            escreval("Digite um valor positivo")
            leia(Q[i])
            fimenquanto
            fimpara
            para i de 1 ate 10 faca
            posicao <- i
            fimpara
fimalgoritmo

nao sei se o que eu fiz ta certo ! 

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@rafaeddd   pelo que entendi , você precisa pegar dez valor e colocar no vetor , e depois imprimir os dez valores que estarão no vetor ,  então você usou certo o laço de repetição ,  e pode ser positivo ou negativo , o enunciado não diz nada sobre isso ,  e na hora de imprimir você esqueceu de colocar a posição do vetor ,   então seu código pode ser assim  :

Algoritmo "7"
// EXERCICIO NUMERO 7
// Disciplina  : [Linguagem e Lógica de Programação]
// Professor   : Lourivaldo Pereira
// Aulo        : Rafael Santos Castilho
var
 Q: vetor[1..10] de inteiro
 i,posicao: inteiro
inicio
  para i de 1 ate 10 faca
    escreval("Digite o", i, "º numero:")
    leia(Q[i])
  fimpara
  para i de 1 ate 10 faca
    escreva(Q[i])
  fimpara
fimalgoritmo

o vetor com dez posições , começando de zero e indo até nove , seria assim , onde cada quadrado é uma posição no vetor e pode receber um dado  , que nesse caso é um dado do tipo inteiro , mas pode ser também do tipo caractere , ou outro :

vetor_dez.thumb.jpg.82a5db0064c2dcdd034d9c92915470f0.jpg

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

1# SOBRE O ENUNCIADO

@rafaeddd, vejamos o que diz o enunciado:

17 horas atrás, rafaeddd disse:

ao entendi como usar vetores 

1961147621_Semttulo.png.f19635a6d561cfc0bffebdde24e0e5c9.png


Inicialmente uma ressalva: tomemos como base que a implementação de uma solução deve está limitada a fazer o que enunciado pede. Não deve fazer algo a mais, nem deve fazer algo a menos. Certo? Caso queira implementar melhorias, poderia fazer um outro código... ou seja, teria um código que tenta satisfazer o enunciado, mas poderia ter outros com possíveis melhoras OU mesmo soluções para interpretações diferentes... Então, nem todo enunciado é claro e objetivo ou é preciso em cada detalhes... ele podem deixar margens a interpretações ou mesmo ser mais abrangentes... por exemplo, esse enunciado fala  "leia o vetor A". Tá, mas que vetor A? É um vetor que já existe de uma questão anterior? o enunciado está incompleto? Então, com só essas informações que temos, poderíamos supor que queria dizer "leia um vetor de inteiros que terá a nomenclatura 'A'". Entende?

 

 

Vamos tentar desmembrar o enunciado:

1) Ler um vetor de 10 posições;

2) Escrever a posição de cada elemento igual a 10.

 

Na primeira parte, o próprio texto já dá uma boa noção do que precisa..., e levando em consideração a "margem de interpretação", seria "ter um vetor de 10 posições, onde cada posição terá um número inteiro"... (ou algo por ai). Você começou implementando nessa base, mas, assim como comentado por @devair1010, tentou implementar algo relacionado "um valor positivo" e tal... ou seja, apesar do enunciado não ser claro, me pareceu que foi "além" do que foi pedido. Resumindo: apenas leia um vetor de inteiros. Não insira essa "limitação" de ser apenas positivos.

 

 

Na segunda parte, creio eu que entra o ponto mais delicado da interpretação. Então, pelo que entendi, você vai "verificar cada uma das posições. Se o valor for igual a 10, você imprime a posição onde está o número". No 2# complemento.

 

 

 

2# Sobre a implementação..

Poderia ser basicamente a implementação de cada uma das partes. Algo com:

// EXERCICIO NUMERO 7
// Disciplina  : [Linguagem e Lógica de Programação]
// Professor   : Lourivaldo Pereira
// Aulo        : Rafael Santos Castilho
algoritmo "Exercício 07"
var
   A :vetor[1..10] de inteiro //vetor A que armazenará 10 números inteiros
   i :inteiro                 //auxiliar para percorrer o vetor
inicio
   //Ler um vetor de 10 posições;
   para i de 1 ate 10 faca
      escreva ("Digite o ",i:2,"º numero: ")
      leia(A[i])
   fimPara


   //Escrever os valores da posições que tem o valor 10.
   
   
   



fimAlgoritmo

A primeira parte já estaria implementada. Faltando a segunda, que poderia tomar como base a implementação de @devair1010:

 

16 horas atrás, devair1010 disse:

  para i de 1 ate 10 faca
    escreva(Q[i])
  fimpara

 

Então, esse trecho está "exibindo os dados do vetor Q". Já no seu código você precisa "verificar o valor contido em cada posição do vetor A, se tiver o valor 10 numa posição, imprime o valor da posição".

 

Dica:

Spoiler

A posição estará na variável i, o seja, se posição tem um valor igual a 10, exibe o valor de i.

 

 

 

***

 

No aguardo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×