Ir ao conteúdo
  • Cadastre-se
André_André

Projeto Transformador Fonte Half-Bridge

Recommended Posts

Boa tarde, pessoal!

 

Estou montando uma fonte chaveada com a topologia half-bridge e encontrei algumas dificuldades ao implementar o transformador da mesma.

 

As especificações da fonte são:

- Tensão de entrada: 50 V;

- Tensão de saída: 30 V;

- Corrente de saída: 10 A;

- Frequência de chaveamento: 50 kHz.

 

O transformador que projetei tem as seguintes características:

- Espiras do primário: 3,3 espiras;

- Espiras do secundário: 5,06 espiras;

- Núcleo de ferrite: EE 42/21/15.

 

Ao testar apenas o transformador com um gerador de funções provendo uma onda quadrada de 10 Vpp e 50 kHz, obtive o sinal mostrado na foto em anexo no primário do transformador, o qual me parece meio esquisito.

No secundário, obtive um sinal com o mesmo comportamento, mas com aproximadamente 15 Vpp (respeitando bem a relação de transformação).

 

A questão é: não deveria haver uma onda retangular tanto no primário quanto no secundário?

 

Agradeço desde já qualquer tipo de ajuda!

 

 

 

primario.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

A resposta em frequência do transformador está dando a ele uma característica de diferenciador GbhmuXl.gif:

 

 

 

enIBvww.gif

 

 

 

No livro The Electronics Handbook é apresentado o circuito equivalente completo de um transformador linear, contendo características resistivas, capacitivas e indutivas.

 

 

 

Lembre-se de que na prática não é fácil construir um transformador de fonte chaveada com a perfeição exigida F5Rua4D.gif.

 

 

 

Espero ter ajudado GbhmuXl.gif.

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, rjjj disse:

A resposta em frequência do transformador está dando a ele uma característica de diferenciador GbhmuXl.gif:

 

 

 

enIBvww.gif

 

 

 

No livro The Electronics Handbook é apresentado o circuito equivalente completo de um transformador linear, contendo características resistivas, capacitivas e indutivas.

 

 

 

Lembre-se de que na prática não é fácil construir um transformador de fonte chaveada com a perfeição exigida F5Rua4D.gif.

 

 

 

Espero ter ajudado GbhmuXl.gif.

 

Obrigado pelo esclarecimento!

Você saberia alguma modificação que eu pudesse realizar para ele funcionar adequadamente?

Realmente as coisas na prática não são tão belas quanto na teoria... Hahaha

Compartilhar este post


Link para o post
Compartilhar em outros sites

@André_André

 

 

Converse com o membro do fórum que fez o tópico abaixo. Acredito que ele é o melhor aqui para discutir sobre esse tema GbhmuXl.gif.

 

 

 

 

 

Espero ter ajudado GbhmuXl.gif.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
34 minutos atrás, André_André disse:

As especificações da fonte são:

- Tensão de entrada: 50 V;

- Tensão de saída: 30 V;

- Corrente de saída: 10 A;

- Frequência de chaveamento: 50 kHz.

 

O transformador que projetei tem as seguintes características:

- Espiras do primário: 3,3 espiras;

- Espiras do secundário: 5,06 espiras;

- Núcleo de ferrite: EE 42/21/15.

 

 

As espiras no secundário são maiores que no primário? 

Mas o secundário não é a tensão menor? 

adicionado 3 minutos depois
38 minutos atrás, André_André disse:

 

Obrigado pelo esclarecimento!

Você saberia alguma modificação que eu pudesse realizar para ele funcionar adequadamente?

Realmente as coisas na prática não são tão belas quanto na teoria... Hahaha

 

Pela imagem parece que está dando pouca indutância para a freqüência que está usando. 

E só existe uma resposta para isso:

Seu modelo de núcleo tem um Gap.

http://www.thornton.com.br/pdf/nee_42_21_15.pdf

 

image.png.d88efb1c7018a82f790d53bf4cec7c20.png


 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@rjjj

 

Obrigado! Pena que estou sem permissão para enviar mensagens privadas... Espero que ele apareça por aqui.

 

@albert_emule

 

É algo estranho mesmo, mas acredito que seja característico da topologia.

 

Segue as minhas anotações de projeto em anexo. Estou usando a tensão máxima de operação como 80 V.

 

Sobre o núcleo, ambas as partes dele encostam perfeitamente uma na outra, assim como na imagem em anexo. Assim, estaria sem gap? Se sim, não poderia ser causado por outra coisa?

 

 

nucleo.jpg

notes.jpg

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, André_André disse:

Sobre o núcleo, ambas as partes dele encostam perfeitamente uma na outra, assim como na imagem em anexo. Assim, estaria sem gap? Se sim, não poderia ser causado por outra coisa?

 

Se as três pernas fecham por completo, sem deixar espaço de ar, então o problema é outro. 

Pode ser que seu gerador de sinal gere o sinal com corrente muito baixa. 

 

Seria interessante montar uma ponte com mosfets para executar estes testes. 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, albert_emule disse:

 

Se as três pernas fecham por completo, sem deixar espaço de ar, então o problema é outro. 

Pode ser que seu gerador de sinal gere o sinal com corrente muito baixa. 

 

Seria interessante montar uma ponte com mosfets para executar estes testes. 

 

 

Agora que você mencionou, talvez a corrente de magnetização do trafo (naturalmente distorcida) esteja predominando na ausência de uma corrente significativa no secundário F5Rua4D.gif.

 

 

 

Sobre a corrente drenada no primário ser muito alta para o gerador de funções, depende da carga no secundário também. Acho que um gerador profissional de bancada já teria disparado alguma proteção ou simplesmente queimado se fosse o caso. Só o que sei é que a tensão de saída de um gerador de funções, via de regra, é projetada para não variar com a corrente de carga (no máximo por volta de 100 mA).

 

 

 

Espero ter ajudado GbhmuXl.gif.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@albert_emule @rjjj

 

Buscarei realizar os testes com mosfets para ver se há alguma mudança no comportamento.

O gerador de funções não alertou nenhum problema durante o teste. Utilizei uma carga de 1k Ohm no secundário, o que não mudou o comportamento do sinal.

 

Vocês acham que poderia ser a pouca quantidade de espiras nos enrolamentos? Talvez dobrar a quantidade em cada um deles poderia aumentar a indutância?

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, rjjj disse:

 Só o que sei é que a tensão de saída de um gerador de funções, via de regra, é projetada para não variar com a corrente de carga (no máximo por volta de 100 mA).

 

 

 

Espero ter ajudado GbhmuXl.gif.

 

 

Deve ser isso.

100mA. Pode ser uma corrente insuficiente. 

 

adicionado 6 minutos depois
2 minutos atrás, André_André disse:

@albert_emule @rjjj

 

Vocês acham que poderia ser a pouca quantidade de espiras nos enrolamentos? Talvez dobrar a quantidade em cada um deles poderia aumentar a indutância?

 

 

 

A área transversal do núcleo é de quantos centímetros??

Área transversal ao quadrado daquela perna que fica no meio, dentro do carretel. 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, André_André disse:

 

Acredito que seja 1,81 cm2 nesse caso.

Para não haver dúvida, conferi com essa calculadora: https://totalcalc.com/181-mm2-to-cm2

 

Para o primário de 50V em 50Khz você enrola 5 espiras. 

O secundário você faz regra se três 

adicionado 20 minutos depois

Screenshot_20181121-001554_Chrome.jpg

adicionado 35 minutos depois

Veja;

http://www.thornton.com.br/formulas.htm

Se você executar a fórmula da onda quadrada o resultado será o mesmo apresentado na calculadora do print. 

As 5 espiras. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@André_André

Olá!

Na referência apresentada pelo colega @rjjj , o cálculo se baseava em um indutor e não em um trafo, como é o seu caso.

Inclusive, acabei de postar uma série de vídeos no YouTube, que trata exatamente dos detalhes da referência mencionada.

Caso se interesse, aí segue o primeiro vídeo da série. Acredito que seja útil.

 

https://youtu.be/DMFB8WJxlTU

 

São um total de 11 vídeos sobre o assunto.

 

Mas com relação às suas dúvidas:

1 - Mataram a primeira charada. Seu gerador de sinais não possui potência para o seu trafo, logo a forma de onda não é sustentada. É aquele ditado "entra lixo, sai lixo".

2 - Mataram, também a segunda charada. É quase certo que o número de espiras esteja errado. 

3 - Quanto ao gap. Não se deve incluir um gap, como se faz em indutores. O único gap que se costuma usar em trafos para fontes chaveadas, tem a finalidade de evitar o surto de corrente inicial, quando se liga o equipamento. E neste caso, o gap deve ser menor que a espessura de uma folha de papel comum.

 

O primeiro passo não é escolher o núcleo e sim calcular o parâmetro Ap (Area product, ou produto das áreas). Ap é definido como o produto da área da janela do núcleo com a área da seção transversal do núcleo. No caso de querer usar dois núcleos EEs, a área da janela é a soma das áreas formadas pela região onde os fios serão enrolados (os dois Es juntos). É conhecida como Wa (Window area). O outro termo (área) é definido como a área da seção transversal da perna central do núcleo (Area core, ou Ac).

Como você não possui nenhum dos dois valores, primeiramente se calcula o Ap (a unidade é Cm elevado a quarta potência).

Com este valor é que se procura, no manual do fabricante, o núcleo que possui o valor mais próximo do desejado (calculado).

Se você realmente quiser calcular corretamente o trafo, acharia melhor consultar o livro que apresento em minha referência.

 

Em tempo: O valor da densidade de campo magnético, que consta na dica do nosso colega Albert_Emule (2800) vai fazer com que esse núcleo sature, o que se deve evitar, pois deve queimar as chaves (transistores ou MOSFETs). Um valor mais adequado seria uns 1500 Gaus. Na referência, no cálculo de AP, a unidade do B é Tesla (1T = 10.000 Gaus)

 

Bons projetos.

MOR_AL

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites
25 minutos atrás, André_André disse:

Boa noite, pessoal.

 

O transformador funcionou com o novo número de espiras.

 

Obrigado!

 

Conseguiu os 10A em 30V? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×