Ir ao conteúdo
  • Cadastre-se
João Pedro Valle

VisualG Resolução de Exercícios de Matriz

Recommended Posts

Galera eu preciso da resolução desses algoritmos (Matriz) até amanhã por favor

1) Faça um algoritmo que leia 9 uma matriz 3x3. Posteriormente, percorra esta matriz e imprima somente os números que são pares.

2) Faça um algoritmo que leia uma matriz 2x3 e verifique se a matriz possui algum número repetido. Informe "Possui" ou "Não Possui" ao final do algoritmo.

3) Faça um algoritmo que possua duas matrizes 4x4 de números inteiros. Posteriormente, imprima somente os números que estão nas duas matrizes.

4) Faça um algoritmo que leia uma matriz 3x3 e imprima esta matriz ordenada de forma crescente.

 

 

POR FAVOR RESPONDAM!!!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1)

algoritmo "Questão 1"
// Função :
// Autor :
// Data : 01/12/2018
// Seção de Declarações
var
v:vetor [1..3,1..3] de inteiro
i,j:inteiro
inicio
para i de 1 ate 3 faca
   para j de 1 ate 3 faca
      leia(v[i,j])
   fimpara
fimpara

para i de 1 ate 3 faca
   para j de 1 ate 3 faca
      se (v mod 2 = 0) entao
         escreval(v[i,j])
      fimse
   fimpara
fimpara
fimalgoritmo

 

2)

algoritmo "Questão 2"
// Autor : João Pedro Valle
var
v:vetor[1..2,1..3] de inteiro
i,j:inteiro
inicio
para i de 1 ate 2 faca
     para j de 1 ate 3 faca
          leia(v[i,j])
     fimpara
fimpara

para i de 1 ate 2 faca
     para j de 1 ate 3 faca
          se (v[i,j])=(v[i,j]) entao
          escreval("Possui")
          se  (v[i,j])<>(v[i,j]) entao
          escreval("Não Possui")
     fimpara
fimpara
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Para a primeira questão, faltou especificar as coordenadas da matriz.

2 horas atrás, João Pedro Valle disse:

se (v mod 2 = 0) entao

 

Seria:

2 horas atrás, João Pedro Valle disse:

se (v[i,j] mod 2 = 0) entao

 

Para essa questão, sugiro também exibir textos de interações, ou seja, não ficar apenas um cursor piscando na tela, e nem só ficar um monte de número ao final. Ex.:

algoritmo "Questão 1"
//Função: Programa que verifica os números pares de uma matriz de números inteiros
//Autor : João Pedro Valle
//Data  : 01/12/2018
//
//1) Faça um algoritmo que leia 9 uma matriz 3x3. Posteriormente, percorra esta
//matriz e imprima somente os números que são pares.
//
var
   v   :vetor [1..3,1..3] de inteiro
   i,j:inteiro
inicio
   escreval("Insira dos dados da matriz")
   escreval()
   ALEATORIO -20,99
   para i de 1 ate 3 faca
      para j de 1 ate 3 faca
         escreva ("Matriz[",i:1,",",j:1,"]: ")
         leia(v[i,j])
      fimpara
   fimpara
   ALEATORIO OFF
   escreval()
   escreva ("Números pares na matriz: ")
   para i de 1 ate 3 faca
      para j de 1 ate 3 faca
         se (v[i,j] mod 2 = 0) entao
            escreva (v[i,j])
         fimse
      fimpara
   fimpara
   escreval()
fimalgoritmo

 

adicionado 19 minutos depois

2#
Para o segundo código você implementou:

3 horas atrás, João Pedro Valle disse:

se (v[i,j])=(v[i,j]) entao

 

Está comparando cada posição com a própria posição, ou seja, sempre vai ser igual. Mas o que você precisa é comparar cada posição da matriz, com cada umas das posições sucessoras. (obs.: as anteriores não precisa, pois já foram verificadas)

Comparar a posição a11 com a12, a13, a21, a22 etc;

Comparar a posição a12 com a13, a21, a22, a23 etc  (veja que a12 já foi comparado com a11 na linha acima);

etc

adicionado 27 minutos depois

Dica 1:
Em vez de 2 para, você poderia utilizar 4. Seria um par de para para cada "posição atual", e outro par de para para percorrer as posições sucessivas.

 

Dica2:

Se tiver dificuldades para fazer o segundo par de para ir da posição sucessiva em dia, pode colocar para percorrer toda a matriz, mas não podendo comparar quando as coordenadas são iguais.

adicionado 36 minutos depois
3 horas atrás, João Pedro Valle disse:

3) Faça um algoritmo que possua duas matrizes 4x4 de números inteiros. Posteriormente, imprima somente os números que estão nas duas matrizes.

4) Faça um algoritmo que leia uma matriz 3x3 e imprima esta matriz ordenada de forma crescente.

 

Para o 3, simplesmente compare cada posição de uma matriz com todas as posições da outra. Acho que essa questão é mais fácil que a 2. Poderia fazer ela primeiro!

 

Para o 4, poderá (deve) usar algum algoritmo de ordenação na matriz. Não precisa, e nem deve, tentar reinventar a roda, ou seja, parar para pensar "como faz para ordenar uma matriz"... apenas vai utilizar uma técnica pronta. Uma das mais simples, e mais famosa, é o Bubble Sort. No caso, estude a fundo como funciona esse método e implemente no seu código. ;)

 

 

 

***

 

Escolha um exercício para fazer. Tenta responder e posta o código aqui para analisarmos se ficou certinho ou, se tiver dificuldades, informar em qual parte.

 

 

Qualquer dúvida sobre alguma parte que comentei, é só falar (escrever, rs).

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×