Ir ao conteúdo
  • Cadastre-se
Horse With No Name

VisualG Calculadora Visual G - Usando as Funções

Recommended Posts

Faz tempo que não brincava com Visual G, eu usava pra ensinar pessoas que estavam querendo entrar na area de TI.

 

Um assunto sempre bom a abordar são as funções, elas podem ainda ser confusos pra muitas pessoas que estão iniciando.

 

ao ouvir o termo "Procedimento ou Procedure" , "Função ou Function", podemos ter uma percepção do que pode ser na questão de interpretar cada palavra.

 

Fiz Aqui um algoritmo usando a função, eu posso chama-la a qualquer momento em meu script.

 

Vou deixar o Script pra vocês interpretarem, qualquer duvida, só me citar que eu respondo qualquer duvida do código pra ajudar mesmo o entendimento

 

Algoritmo "calculadora"

//função de Adição Matematica
funcao soma(a,b:real):real
inicio
   retorne (a+b)
fimfuncao

//função de Subtração Matematica
funcao sub(a,b:real):real
inicio
   retorne (a-b)
fimfuncao

//função de Multiplicação Matematica
funcao mult (a,b:real):real
inicio
   retorne (a*b)
fimfuncao

//função de Divisão Matematica
funcao divs (a,b:real):real
inicio
   retorne (a/b)
fimfuncao

Var
   escolhe_num: inteiro
   numeroa:real
   numerob:real
   GuardaResultado: real

Inicio
   repita
   MudaCor("Preto","Fundos")
MudaCor("Amarelo","Frente")
escreval("Calculadora")
escreval()
escreval("1- Adição")
escreval("2- Subtração")
escreval("3- Multiplicação")
escreval("4- Divisão")
escreval("5- Limpar a Tela")
escreval("6- Sair da Calculadora")
leia(escolhe_num)

//adição
se escolhe_num = 1 entao
   limpatela
   escreval("Digite o primeiro Numero:")
   leia(numeroa)
   escreval()
   escreval("Digite o segundo Numero:")
   leia(numerob)
   GuardaResultado <- soma(numeroa,numerob)
   escreval("O Resultado da Soma é:",GuardaResultado)
fimse

//subtração
se escolhe_num = 2 entao
   limpatela
   escreval("Digite o primeiro Numero:")
   leia(numeroa)
   escreval()
   escreval("Digite o segundo Numero:")
   leia(numerob)
   GuardaResultado <- sub(numeroa,numerob)
   escreval("O Resultado da subtração é:",GuardaResultado)
fimse

//multiplicação
se escolhe_num = 3 entao
   limpatela
   escreval("Digite o primeiro Numero:")
   leia(numeroa)
   escreval()
   escreval("Digite o segundo Numero:")
   leia(numerob)
   GuardaResultado <- mult(numeroa,numerob)
   escreval("O Resultado da multiplicação é:",GuardaResultado)
fimse

//Divisão
se escolhe_num = 4 entao
   limpatela
   escreval("Digite o primeiro Numero:")
   leia(numeroa)
   escreval()
   escreval("Digite o segundo Numero:")
   leia(numerob)
   GuardaResultado <- divs(numeroa,numerob)
   escreval("O Resultado da divisão é:",GuardaResultado)
fimse

//limpatela
se escolhe_num = 5 entao
   limpatela
fimse

//sair do programa
se escolhe_num = 6 entao
   escreval("Saindo da Calculadora, Obrigado por Utilizar!")
fimse

//Digitou outro numero fora de (1..6)
se escolhe_num > 6 entao
   escreval("voce digitou um numero não correspondente as opções acima")
fimse
ate escolhe_num = 6

Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×