Ir ao conteúdo
  • Cadastre-se
Ariane Fialho Macedo

Excel Numerar base de dados

Recommended Posts

Olá pessoal!

 

Tenho uma base clientes em excel com o cnpj se repetindo por diversas linhas. Não posso unificar as linhas, pois cada uma corresponde a um número de nota fiscal distinto. Porém, preciso numerar estes clientes por cnpj.

Ex:

image.png.ad0a502a3ac7f53b14a33cb6d29c8c42.png

Qual formula utilizar na coluna número cliente para que esta classificação seja automática?

Podem me ajudar?

 

Obrigada!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ariane Fialho Macedo boa tarde,

 

Eu faria um autofiltro.

Procedimento: vai na Linha que tem os títulos NFE, CNPJ, Número do Cliente etc... e clica em cima da linha (lá no canto esquerdo, provavelmente linha "1"). Agora vá nas abas do Excel e procure Dados > Filtro clique nesta opção e vai gerar um filtro. Feito isto, vá na coluna CNPJ clique na seta ao lado e vai abrir as opções classifique de forma que desejar.

 

Desta forma as colunas vão ficar com uma seta ao lado e você poderá Classificar a coluna CNPJ que irá automaticamente ordenar as colunas que possuem o filtro.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Gustavinhu boa tarde! obrigada pelo retorno.

 

Infelizmente autofiltro não resolve o problema. Porém, encontrei uma alternativa:

- copiei a coluna cnpj para outra aba;

- selecionei a coluna (na outra aba), fui em dados - remover duplicatas;

- posteriormente, na coluna ao lado do cnpj, na linha 2, inseri o número 1, e na linha abaixo inseri a fórmula =B2+1 e arrastei até a última linha;

- depois voltei na aba anterior e fiz um procv do cnpj na nova aba =PROCV(A2;Plan2!$A$1:$B$500;2;FALSO), e retornei a coluna B com os números. 

 

Espero ajudar alguém com a mesma dúvida.

 

Obrigada!

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ariane Fialho Macedo  bom dia,

 

Que ótimo que conseguiu resolver desta forma.

Na minha sugestão eu achava que não poderia remover as duplicadas. hehehehehehe

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×