Ir ao conteúdo
  • Cadastre-se
Rogério André Queke Júnior

VisualG Dificuldade em escrever um código usando matrizes

Posts recomendados

Olá boa tarde, estou estudando lógica de programação, estou tentando resolver um problema de matrizes, travei em uma parte do código e não consigo sair.

Segue o código completo abaixo

Na tela de comandos mostra o seguinte aviso: "VisualG encontrou o seguinte problema na linha 26:"

"Esperava encontrar '['.

 

1- Algoritmo "eleição matriz"

2- Var

3-     candidatos : vetor [0..1,0..2] de caracter

4-     linha : inteiro
5-     votos : inteiro

6-     opcao : inteiro

7-   votosBranco : Inteiro
8- Inicio

9-       //lista de candidatos

10-     para linha de 0 ate 1 faca

11-     escreval ("Qual o nome do candidato?")

12-    leia(candidatos[linha,0])

13-    escreval ("Qual a legenda do candidato?")
14-   leia (candidatos[linha,1])
15- FIMPARA

16-         ENQUANTO (opcao <> 3) FACA
17-         escreval ("1 - Para votar")
18-         escreval ("2 - Para votar em branco")
 19-        escreval ("3 - Finalizar votação")
20-         leia(opcao)

21-        ESCOLHA opcao
 22-      CASO 1
23-       //listar os candidatos
 24-     Escreval ("Digite o número do seu candidato")
 25-     Leia (candidatos[linha])

26-       candidatos([linha,0]) <- caracpnum(votos)
27-       candidatos([linha,1]) <- caracpnum (opcao)

28-

29-       CASO 2
            //votar em branco

 

      CASO 3
         //finalizar votação
      fimescolha

Fimalgoritmo

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Rogério André Queke Júnior         na linha 25 você colocou apenas hum elemento para a linha e faltou o outro para a coluna , e na linha 26 você está passando um inteiro para inteiro e colocando em um vetor de caracteres , então nesse caso você precisa transformar esse inteiro em caractere  usando o comando numPcarac .   mas creio que a logica não esteja certa , pois você preencheu o vetor com o nome e a legenda do candidato , e ali no caso você está sobrescrevendo o que foi gravado nesse mesmo vetor .

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!