Ir ao conteúdo
  • Cadastre-se
Andre_deto

Excel RESOLVIDO função se com intervalo de células

Posts recomendados

Bom dia, Preciso fazer um planilha de controle de datas com "Farol" Vermelho, Amarelo ou Verde dependendo das datas e condições que eu criar. Eu estou fazendo, por exemplo, =SE(Bacen!G4="Prazo em Risco";"Vermelho";SE(Bacen!G5="Prazo em Risco";"Vermelho";SE(Bacen!G6="Prazo em Risco";"Vermelho";SE(Bacen!G4="Amarelo";"Amarelo";SE(Bacen!G5="Amarelo";"Amarelo";SE(Bacen!G6="Amarelo";"Amarelo";"Verde")))))) mas é um intervalo relativamente pequeno e estou querendo adaptar essa fórmula para um intervalo de células bem maiores, como posso fazer isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde @Andre_deto

 

Seja bem-vindo ao fórum!

 

Anexe aqui no fórum um arquivo Excel, pode sr com dados fictícios, mas com a mesma estrutura, digitando o resultado esperado para cada situação.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado Pelas boas vinda, Patropi.

 

Alterei a planilha e estou anexando aqui. Veja os exemplos A, B e C como eu fiz e agora busco uma solução para a EMPRESA D que possui uma série de atividades bem grandes.

 

Abraços

Teste Farol - Forum.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Andre_deto

 

O Excel permite você utilizar a formatação com formulas, não precisa aplicar a formula na planilha e depois formatar conforme o texto retornado.

Veja tutorial no link abaixo:

https://www.funcaoexcel.com.br/formatacao-condicional-com-formula/

 

Para falar a verdade eu não entendi qual a tua dúvida, pois não tem explicação de qual o resultado esperado na EMPRESA D

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Patropi, 

 

É uma planilha de cronograma de datas tendo a condicional "Vermelha" como prioridade. Preciso procurar naquele intervalo (G4:G22) se tem algum retorno "Prazo em Risco" como prioridade 1, o retorno "Amarelo" como prioridade 2 e "Verde" prioridade 3, para corresponder na Aba Farol. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

6 horas atrás, Andre_deto disse:

 ... estou querendo adaptar essa fórmula para um intervalo de células bem maiores ...

 

Veja se entendi corretamente.

Cole uma cópia da fórmula abaixo em D3 da planilha Farol e arraste para baixo.

=SE(CONT.SE(INDIRETO("'"&B3&"'!G:G");"Prazo em Risco");"Vermelho";SE(CONT.SE(INDIRETO("'"&B3&"'!G:G");"Amarelo");"Amarelo";"Verde"))

Essa fórmula cobre toda a coluna G de cada uma das planilhas cujos nomes estejam na coluna B da planilha Farol.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@osvaldomp Deu certo na planilha que eu enviei! É exatamente isso que eu tava querendo!! Muito Obrigado! Abraços

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Andre_deto

 

Como a resposta do Osvaldo solucionou a tua dúvida, se esqueceu de clicar em Curtir e marcar o tópico como Resolvido.

Na minha assinatura tem um link com uma instrução de como proceder.

 

[]s

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!