Ir ao conteúdo
  • Cadastre-se
john de souza

Erro interno num software - run time error

Posts recomendados

Bom galera eu trabalho numa empresa que tem um sistema para gerenciar quartos / quem esta nele, etc. 

o que ocorre é o seguinte a empresa começou atualizar os computadores para novos equipamentos e já migrando pro windows 10, bom os computadores com o windows 7 funciona esse sistema de boa, eu instalei ele no windows 10 beleza instala tudo certo porém quando abre funciona 99% tem uma função que exibe o mapa dos quartos e quando tento abrir exibe esse erro: Run-Time error '1007'; Array element invalid data type.
erro-run-time-1007.jpg
Aí começa treta porque eu fui instalar em outro computador com o windows 7 e adivinha o mesmo erro nesta função de exibir o mapa, bom beleza, depois de instalar dezenas de computadores com o windows 10 e instalando este sistema mesmo que com o erro nesta opção, ontem eu instalei em um computador com o windows 10 e funcionou tudo 100% abriu o mapa, tudo ok, agora me deem uma luz , uma ideia, o que eu faço para descobrir o que houve de diferente para funcionar neste equipamento e em todos os outros não. 

*Importante o sistema foi criado por uma empresa que não existe mais e não temos suporte algum.

Se alguém tiver alguma ideia do que eu possa fazer pra tentar sanar o problema, ou identificar o que causa do erro, fico grato desde já.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@john de souza aparentemente é um erro em programas desenvolvidos com VBA, então talvez a versão do Office instalado no sistema pode interferir no funcionamento. Já verificou essa parte? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@navegantenarede Sim em ambos os Sistemas operacionais w7 e w10 estão com o pacote office 2010 standard, porém testei com o pacote office 2013, 2016  e 365, porém ocorreram o mesmo erro (problema).

 

Hoje Fiz um teste, e instalei o sistema em computador com o windows 10 o interessante é que acredito que o procedimento que temos na base está errado, eu segui a ordem inversa dos dois executáveis que instala o mesmo e funcionou, agora tenho que testar em outros equipamentos para ver se é esta a solução, se for, nesse caso vai provar que "A ordem dos fatores alteram sim o resultado". 

 

E assim vou poder alterar a documentação e encerrar este pedido de ajuda, amanhã retornarei informando se ocorreu tudo certo; 

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!