Ir ao conteúdo
  • Cadastre-se
Moustaccium

Excel RESOLVIDO Função SE para aviso de vencimento

Posts recomendados

Salve pessoas, estou tentando colocar em uma planilha um aviso de vencimento para contas:

- Até 3 dias antes de vencer: sem aviso nenhum

- 3 dias até o vencimento: um aviso tipo "Atenção"

- Dia do vencimento: "VCTO hoje"

- Após a data do vencimento: nenhum aviso

 

Dei uma pesquisada para fazer isso mas o negócio não ficou certo. Alguém pode indicar a fórmula aí?

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Experimente:

 

=SE(HOJE()-A1=0;"vence hoje";SE(E(HOJE()-A1<=3;HOJE()>A1);"atenção";""))

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
11 horas atrás, osvaldomp disse:

 

Experimente:

 


=SE(HOJE()-A1=0;"vence hoje";SE(E(HOJE()-A1<=3;HOJE()>A1);"atenção";""))

 

Olá @osvaldomp, obrigado pela fórmula. Era isso que eu precisava, única coisa é que saiu o aviso "atenção" invertido. Preciso que "atenção" me alerte sobre uma fatura que irá vencer logo (dentro do período de 3 dias). Ou seja, considerando a data de hoje (23/10), o aviso "atenção" deveria aparecer para as datas 24, 25, 26/10.

 

Tentei arrumar baseado na sua fórmula mas não deu...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja se assim atende.

=SE(A1-HOJE()=0;"vence hoje";SE(E(A1-HOJE()<=3;A1>HOJE());"atenção";""))

Considerando a data do vencimento em A1, por exemplo, 30/10/19, então a fórmula irá retornar conforme abaixo.

 

até 26/10 ~~~> vazio

de 27/10 a 29/10 ~~~> atenção

em 30/10 ~~~> vence hoje

a partir de 31/10 ~~~> vazio

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Acho que não fui claro.

Em anexo está um arquivo modelo. Neste modelo o aviso "Atenção" deveria aparecer nas contas "I, J, K" que são as contas que irão vencer dentro de 3 dias (considerando a data de hoje como 23/10).

Controle de pagamento teste.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Utilize a fórmula do post #4.

As contas I e J retornarão "atenção", porém a conta K retornará vazio, e só irá retornar "atenção" a partir do dia 27, pois vence dia 30.

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deu certo @osvaldomp!!! Fórmula inserida e a planilha está funcionando na medida! 

Muito obrigado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Moustaccium

 

Faltou você marcar a última resposta do Osvaldo como Resolvido.

Na minha assinatura tem um link para uma instrução sobre o assunto.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...