Ir ao conteúdo
  • Cadastre-se
Lw2001

Excel Adicionar vários critérios em um mesmo argumento

Posts recomendados

Boa noite,

 

Preciso otimizar uma planilha, onde devo localizar lotes específicos de produtos, em uma data específica. Estou utilizando a função SOMASES, estabelecendo um critério de data e outro critério para o lote que quero pesquisar. Conforme o anexo, eu gostaria de pesquisar 4 lotes de uma vez em uma só fórmula, porém, utilizando a função SOMASES, no critério 2, eu só posso adicionar um critério de cada vez por argumento (ex: =SOMASES(L:L;J:J;A2;K:K;G2)+SOMASES(L:L;J:J;A2;K:K;G3)+SOMASES(L:L;J:J;A2;K:K;G4)+SOMASES(L:L;J:J;A2;K:K;G5) ), sendo que eu gostaria que o Excel me desse os 4 de uma só vez, tentei dessa forma: (=SOMASES(L:L;J:J;A2;K:K;G2:G5), mas a função SOMASES não me permite pesquisar mais de um critério e lote por argumento. Imaginem se eu tivesse que procurar 80 lotes, eu teria que somar 80 argumentos SOMASES, dessa forma eu teria excessivos argumentos e poderia me confundir. Existe alguma formula para no caso desse exemplo, eu localizar os 4 argumentos de uma só vez? Agradeço a ajuda de quem puder me ajudar.

Pasta1.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

1. Selecione a tabela de dados > vá até Pagina Inicial > Formatar como tabela

 

2. Vá até inserir > segmentação de dados > Selecione Data e Lotes

 

3. insira em qualquer lugar essa fórmula : =SUBTOTAL(9;L:L)

 

4. Faça o filtro como desejar

 

 

Pasta1.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lw2001 , Bom Dia.

 

Usa desta forma

 

=SOMARPRODUTO(($J$2:$J$8=A2)*(SINAL(SEERRO(CORRESP($K$2:$K$8;$G$2:$G$5;0);0)))*($L$2:$L$8))

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia @André_Arruda

 

Além da ótima sugestão do André, outra opção é utilizar a função SOMARPRODUTO que permite somar vários critérios sem necessitar repetir a fórmula.

=SOMARPRODUTO((($K$2:$K$10000=G2)+($K$2:$K$10000=G3)+($K$2:$K$10000=G4)+($K$2:$K$10000=G5))*($J$2:$J$10000=A2)*($L$2:$L$10000))

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@deciog eu gostei muito da sua sugestão assim como as outras, todas me foram úteis, me ajudaram muito. Eu gosto de entender as fórmulas, só não entendi o que a função SINAL altera nessa fórmula você poderia me explicar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lw2001 , Bom DIa.

 

Eu acho que você gostaria da função SINAL,

 

Essa função muda o valor acima de 1 para 1 e igual a zero fica zeros

 

Antes da Função SINAL
{1;1;4;2;2;1;4}

Com a função SINAL
{1;1;1;1;1;1;1}

 

Assim consigo fazer a multiplicação

Espero ter ajudados

 

Decio
 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@deciog @deciog Boa tarde,

 

Entendi perfeitamente, obrigado!

 

Ainda sobre sua fórmula, peço mais uma ajuda por gentileza. Estou observando que quando adiciono mais lotes na planilha na coluna K, ou se aciono mais uma linha com o lote em branco, o valor dessa linha no campo faturamento (que fica na coluna L) é adicionado automaticamente a sua fórmula. Ou seja, os lotes da coluna G não estão referenciando a fórmula, somente a data. Pra puxar somente os lotes que eu quero na coluna G, preciso por mais algum argumento?

 

Desde já muito obrigado pela atenção.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lw2001 , Boa Tarde

 

Eu aumente a células para que possa comparar nota a diferença da anterior

 

=SOMARPRODUTO(($J$2:$J$200=A2)*(SINAL(SEERRO(CORRESP($K$2:$K$200;$G$2:$G$15;0);0)))*($L$2:$L$200))

 

Caso precisar aumenta você ok

 

Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes de Computadores - Gabriel Torres

PROMOÇÃO DE QUARENTENA

De R$ 39,90 por apenas R$ 9,90 só até as 23h59min desta sexta-feira 03/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!