Ir ao conteúdo
  • Cadastre-se
Bikke

Excel RESOLVIDO Correção na fórmula para a função SE, Excel 2003 e 2007

Posts recomendados

Boa noite

 

Venho solicitar ajuda numa fórmula, na qual não estou a conseguir acertar .

 

Tenho duas células, G9 E I9

 

Na célula G9, poderá ter dois números, 9 ou 188

Na célula I9, deverá ser igual ou superior a 55 ou igual a 85 ou superior.

 

Ou seja, se na célula G9 tiver o número 9 e na célula I9 tiver o número 85 ou superior, deverá aparecer a mensagem Pedir junta Médica em L9.

ou se na célula G9 tiver o número 188 e na célula I9 tiver o número 55 ou superior, deverá aparecer a mensagem Pedir junta Médica em L9.

 

Já tentei com a seguinte fórmula, mas não está a dar, provavelmente falta alguma coisa.

 

=SE(E(G9="188";I9>="55 dia(s)";G9="9";I9>="85 dia(s)";"Pedir Junta Médica");"")

 

Obrigado pela atenção

 

Cumprimentos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Bikke.

 

Veja se ajuda.

 

=SE(OU(E(G9=9;I9>=85);E(G9=188;I9>=55));"Pedir ...";"")

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite osvaldo

 

Obrigado pela tua resposta.

 

Dar deu, mas tem uma coisa, assim que eu coloco o número 9 ou o número 188 em G8, aparece logo a mensagem, e não deve aparecer, só deverá aparecer quando estiverem reunidas as duas condições, ou seja, quando tiver o número 9  em G8 e quando tiver o número 85 ou superior em I8, ou o número 188 em G8, e quando tiver o número 55 ou superior em I8 é que deverá aparecer a mensagem.

 

O que está a acontecer é assim que eu coloco o Número 9 ou o Número 188 em G8, aparece logo a mensagem, e não deve acontecer.

 

Já agora..
 

Venho pedir mais uma coisa para ficar completo este projecto.

 

Gostaria que, assim que eu clicar na Caixa de Verificação que se encontra em M8 até M50 ( poderá vir a ter mais ), apareça a palavra Sim por baixo da Caixa de Verificação conforme está na planilha, e quando está desactivada a palavra Sim fica oculta.

 

Obrigado desde já pela tua atenção.

 

Cumprimentos

P.S. Planilha anexada

 

Junta.medica_V1.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 14/01/2020 às 17:19, Bikke disse:

Na célula I9, deverá ser igual ou superior a 55 ou igual a 85 ou superior.

 

 

14 horas atrás, Bikke disse:

O que está a acontecer é assim que eu coloco o Número 9 ou o Número 188 em G8, aparece logo a mensagem, e não deve acontecer.

Isso ocorre porque no post anterior você omitiu a informação que em I8 há fórmula que pode retornar vazio.😕


=SE(OU(E(G8=9;I8>=85);E(G8=188;I8<>"";I8>=55));"Pedir Junta Médica";"")

 

 

Gostaria que, assim que eu clicar na Caixa de Verificação ...

Aqui aparece como Label 🤔

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite

 

Tens toda a razão osvaldo, peço desculpa pelo lapso. 😟😟

 

E sim, assim ficou resolvido esse problema na fórmula.

 

Quanto à Caixa de Verificação, voltas a ter razão, é uma Label sim.

 

Peço desculpa por este contratempo e pelo transtorno causado.

 

 

Post editado

 

Para não me dares nas orelhas, (  😜😜😜  )  retirei as células mescladas, e assim, as Labels vão desde a célula M8 até à célula M67, ( são ao todo 60 ).

 

Já agora, para ficar mais operacional, assim que clicasse na Label para fazer aparecer a palavra Sim em M8 até M67, desapareça ( oculte ) a frase "Pedir Junta Médica", que se encontra na célula L8 até L67.

 

Os meus agradecimentos pela tua preciosa ajuda

 

Cumprimentos

 

Planilha actualizada anexada

Junta.medica_V1.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite osvaldo

 

Osvaldo, coloquei a formula que tu disseste: =SE(OU(E(G8=9;I8>=85);E(G8=188;I8<>"";I8>=55));"Pedir Junta Médica";"")

parecia estar tudo bem, mas pelo que eu agora vejo, não está.

 

Eu coloco o numero 9 em G8 até G67, e aparece logo a mensagem "Pedir......", e assim que eu coloco a data em H8 até H67, a mensagem desaparece.

 

Não estou a perceber nada disto.

 

Só acontece com o número 9, se eu colocar o número 188, não aparece a mensagem "Pedir.....".

 

Porque é que isto acontece???

 

Podes me ver isto, sff ??

 

Obrigado

 

Cumprimentos

 

 

Planilha anexada

 

Junta.medica_V0.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites
57 minutos atrás, Bikke disse:

Só acontece com o número 9, se eu colocar o número 188, não aparece a mensagem "Pedir.....".

Porque é que isto acontece???

Ainda é devido à fórmula em I8. Experimente a fórmula abaixo. Inclui também nesta fórmula a condição que você colocou após a edição do post #5 (a propósito, para que o usuário seja notificado sobre a edição me parece que é preciso clicar em @mencionar).

E parabéns pelo rompimento da sua paixão pelas células mescladas 😜👏👏👏👏👏👏👏👏

 

=SE(M8="Sim";"";SE(OU(E(G8=9;I8<>"";I8>=85);E(G8=188;I8<>"";I8>=55));"Pedir Junta Médica";""))

Sobre marcar/desmarcar a Label para inserir/remover o texto "Sim" da célula, vi que você colocou um código VBA para cada Label.

Eu sugiro outro caminho, coloque um único código sob o evento BeforeDoubleClickDoubleClick, que atenderá a toda a planilha, pois não é aconselhável colocar uma Label para cada registro. Imagine uma planilha com 5 mil registros, o que implicará em 5 mil Labels, 5 mil códigos VBA, ...

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado osvaldo, mas não resolveu.

 

Eu coloco o número 9 G8, e depois coloco a data ( 20-12-2019 ) em I8, dá 30 dias, à data de hoje (19-01-2020), aparece logo a mensagem "Pedir....", não devia, pois só aos 85 dias.

 

A tua formula: =SE(M9="Sim";"";SE(OU(E(G9=9;I9<>"";I9>=85);E(G9=188;I9<>"";I9>=55));"Pedir Junta Médica";""))

 

Retirei o que se encontra a vermelho em cima: =SE(OU(E(G8=9;I8<>"";I8>=85);E(G8=188;I8<>"";I8>=55));"Pedir Junta Médica";"")

 

Pois sem o Sim a funcionar, não me interessava essa parte.

 

E a mensagem aparece antes da data prevista, não devia.

 

Quando às Labels, ao se clicar aparecer a palavra Sim, eu fiz-te um pedido de resolução nesse campo no Post #5, e até agora tenho estado à espera da tua preciosa ajuda.

 

Se não for muito incomodo, gostaria que me desses uma ajuda aí.

 

As Labels vão desde a Label 1 célula M8 até à Label 60 célula M67

 

Obrigado

 

Cumprimentos

Compartilhar este post


Link para o post
Compartilhar em outros sites
54 minutos atrás, Bikke disse:

Eu coloco o número 9 G8, e depois coloco a data ( 20-12-2019 ) em I8, dá 30 dias, à data de hoje (19-01-2020), aparece logo a mensagem "Pedir....", não devia, pois só aos 85 dias

 

 

Será que estamos tratando da mesma planilha ou de planilhas diferentes ?

Tomando por base o arquivo do post #6:

Em I8 há fórmula que retorna ou vazio ou quantidade de dias, não é para você colocar data lá.

A data deve ser colocada manualmente em H8, e aí, considerando a data de hoje (19/01/20), a fórmula em I8 irá retornar  85 >= dias se H8 < 27/10/19, e nessa situação é a fórmula em L8 retornará "Pedir ..."

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estamos a falar da mesma planilha.

 

Olhe a imagem que anexei.

Pedir.png

 

Formula: =SE(OU(E(G8=9;I8<>"";I8>=85);E(G8=188;I8<>"";I8>=55));"Pedir Junta Médica";"")

 

Só devia aparecer quando aparecesse 85

Compartilhar este post


Link para o post
Compartilhar em outros sites

Planilha anexada para veres.

Ou então é o meu excel que está marado..

 

Junta.medica_V0.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

O erro ocorre porque a sua fórmula em I mostra 30 dia(s) e esse resultado é texto. Altere a fórmula para mostrar somente 30.

Se for necessária a informação de que se trata de dias (e não horas, meses, anos,...) coloque essa informação no título de coluna e não na fórmula.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ups

 

Já alterei e não aparece mais.

 

Peço desculpa, pois não pensei que isso pudesse ter influência no resultado final, e tem.

 

Corrigido.

 

Peço-te então, que se pudesses ajudar nas Labels, que é o que me falta.

 

Os meus agradecimentos e desculpa todo este transtorno.

 

Cumprimentos

Compartilhar este post


Link para o post
Compartilhar em outros sites
28 minutos atrás, Bikke disse:

Peço-te então, que se pudesses ajudar nas Labels, que é o que me falta.

 

Não me ocorre uma solução viável utilizando Labels. Veja os comentários no post #7.

Compartilhar este post


Link para o post
Compartilhar em outros sites

E se em vez de Labels, for uma CheckBox ??

 

Queria evitar que se escrevesse, e sim, ao se clicar nas CheckBox aparecesse " Junta Médica Pedida " em uma célula á frente, neste caso poderia ser em N8.

 

Ou colocar Caixas de Verificação.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Cole uma cópia do código abaixo no módulo da planilha.

funcionamento - a cada duplo clique em qualquer célula da coluna M, o conteúdo da célula clicada irá alternar entre "Sim" e vazio

Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
 If Target.Column <> 13 Then Exit Sub
 Target.Value = IIf(Target.Value = "", "Sim", ""): Cancel = True
End Sub

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite

 

Excelente @osvaldomp .

 

Ficou cinco estrelas.

 

Os meus agradecimentos, pela tua paciência e pela tua excelente ajuda.

 

Continuação de uma boa semana.

 

Cumprimentos.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Eletrônica

PROMOÇÃO DE QUARENTENA

Aproveite o isolamento social para aprender eletrônica!
De R$ 39,90 por apenas R$ 19,90
Só até as 23h59min desta sexta-feira 10/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!