Ir ao conteúdo
  • Cadastre-se
Beiral

Excel somases + subtotal = respeitar o filtro

Posts recomendados

Nessa planilha, preciso somar valor PAGOS (J3) e PAGAR J5) entre um período determinado. 

Ocorre que, a soma NÃO ESTÁ RESPEITANDO O FILTRO (coluna B).

Toda ajuda será bem vinda

Pasta2.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Beiral , Bom Dia.

 

Na celula J3 coloca esta formula

 

=SOMARPRODUTO(SE(($C$9:$C$997>=H3)*($C$9:$C$997<=I3)*(J9:J997<>"Quitada");$D$9:$D$997*SUBTOTAL(3;DESLOC($E$9;LIN($C$9:$E$997)-LIN($E$9);))))

 

Na celula J5 coloca esta formula

 

=SOMARPRODUTO(SE(($C$9:$C$997>=H5)*($C$9:$C$997<=I5)*(J9:J997<>"Quitada");$D$9:$D$997*SUBTOTAL(3;DESLOC($E$9;LIN($C$9:$E$997)-LIN($E$9);))))

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio
 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Primeiro, muito grato pela ajuda, prezado Decio.

 

Segui as instruções mas infelizmente não deu certo. Creio que se trata de um pequeno ajuste na fórmula.

 

No anexo Pasta3 está o arquivo com a fórmula já inserida conforme você orientou.

Pasta3.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Beiral < bom Dia.

 

Foi ótimo você ter postado com a formula, aqui funcionou corretamente estou com versão do Excel de 2019, se você abrir e der erro novamente, então, encerra com CTRL+SHIFT+ENTER, pois na minha versão não precisa

 

No link esta o arquivo com a formula https://www.sendspace.com/file/a1mgr0

 

Confere de retorno 

 

Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Prezado, deu tudo certo. Muito Grato.
Parabéns pela presteza.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes de Computadores - Gabriel Torres

PROMOÇÃO DE QUARENTENA

De R$ 39,90 por apenas R$ 9,90 só até as 23h59min desta sexta-feira 03/04/2020

CLIQUE AQUI E COMPRE AGORA MESMO!