Ir ao conteúdo
  • Cadastre-se
Ellif

Excel Pular linha - Condição por cor

Posts recomendados

Galera é o seguinte, tenho uma planilha no formato abaixo:

image.png.0ed5b6b5d24ef667dd409b8d1ec77d7a.png

O que acontece é: Eu preciso dos dados da coluna A, apenas daqueles que tem SOP, percebi um padrão que todos que tem SOP é verde. 

 

Então no caso, eu precisaria apenas do dados que contém nas linhas verdes, ele teria que pular a linha branca e trazer os dados da linha verde. 

 

Alguém poderia me ajudar ??

Compartilhar este post


Link para o post
Compartilhar em outros sites

de que forma voce precisa dos dados?

puxar via formula? só extrair dali pra outro lugar (tipo ctrl C ctrl V)?

Você tem certeza absoluta que os "SOP" estão somente nas verdes? (isso pode criar um problema mais pra frente)

 

você tem as planilhas (dados e destino) para analise?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Eder Neumann  Segue planilha. Eu preciso extratir exatamente "SOP XXXX" e os quadros numeros que vem depois. 

Planilha.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ellif , Boa Tarde

 

É possível por formula procurar os "SOP", mas gostaria que mostra na planilha em qual coluna e digita um resultado para melhor entendimento

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ellif , Bom Dia.

 

Na minha versão do Excel não preciso de teclar CTRL+SHIFT+ENTER, talvez a sua precisa

 

Link https://www.sendspace.com/file/mimba3

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio
 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@deciog CTRL+SHIFT+ENTER não funciona, nem só CTRL+ENTER ou SHIFT+ENTER. 

 

Eu coloco a formula, tento uma das combinações acima e mesmo assim não vai. 😞

adicionado 4 minutos depois

@deciog @deciog CTRL+SHIFT+ENTER não funciona, nem só CTRL+ENTER ou SHIFT+ENTER. 

 

Eu coloco a formula, tento uma das combinações acima e mesmo assim não vai. 😞.

 

Meu excel esta em Inglês!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ellif

, Bom Dia.

 

Notei então que sua versão do Excel é menor de 2013, segue formula para funcionar em todas

 

Na minha versão do Excel não preciso de teclar CTRL+SHIFT+ENTER, A sua verão precisa encerrar com CTRL+SHIFT+ENTER

 

Link https://www.sendspace.com/file/9pvidw

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir,na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@deciog Infelizmente continua da mesma forma 😞

 

CTRL+SHIFT+ENTER não funciona. Em anexo planilha com tentativa, o valor simplesmente não vai. 

 

Obrigada pela ajuda!

 

image.png.7912fba0fb921e927d73273d54605305.png

 

image.png.4a843b0525036b77b94569031b416bc5.png

Planilha 3 Decio.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia, colegas!

 

Não analisei quanto à efetividade da solução do Décio, somente em relação ao erro de compatibilidade de versões.

Ocorre que o Décio já está usando a versão do Office 365 que conta agora com as novas funções tipo Matrizes Dinâmicas (um símbolo de arroba aparece antes da função, por exemplo @ÍNDICE(...).

Se um mesmo arquivo é então aberto num Excel, mesmo recente, mas que não esteja com essa atualização instalada (ou talvez a questão do seu Excel ser em inglês?), a nova função aparece como erro e você verá na fórmula, por exemplo,

... _xlfn.SINGLE(FunçãoNormal...)

 

Então, ou você teria que refazer a fórmula eliminando o _xlfn.SINGLE(), por exemplo em O3 de

=SEERRO(_xlfn.SINGLE(ÍNDICE($B$2:$K$37;MENOR(SE(ÉNÚM(LIN($A$2:$A$37)-LIN($A$2)+1/ÉNÚM((LOCALIZAR("SOP";$A$2:$A$37;1))));LIN($A$2:$A$37)-1);LIN(A1));CORRESP(O$2;$B$1:$K$1;0)));"")

Para:

=SEERRO(ÍNDICE($B$2:$K$37;MENOR(SE(ÉNÚM(LIN($A$2:$A$37)-LIN($A$2)+1/ÉNÚM((LOCALIZAR("SOP";$A$2:$A$37;1))));LIN($A$2:$A$37)-1);LIN(A1));CORRESP(O$2;$B$1:$K$1;0));"")

dando C.S.E. ao final, ou atualizar seu Office para as novas funcionalidades. Alguns usuários estão tendo que fazer isso através de reparação do Office. Veja por exemplo o caso do Pietro Farias em "Erro prefixo _xlfn.SINGLE"

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ellif ,

 

Funcionou afinal? se não posta a imagem da célula com erro e a formula dela

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!