×
Ir ao conteúdo
  • Cadastre-se

VisualG Singular e plural no Portugol


Posts recomendados

Olá pessoal, sou novo nisso de programar e estava acompanhando o conteúdo de Portugol de um curso que comprei e durante um exercício eu pensei em implementar algo, mas não faço ideia de como fazer isso. O exercício em questão é sobre o troco de certa mercadoria e quando sai o resultado aparece escrito "reais", ai eu fiquei pensando "E se o valor for 1 real? como eu coloco esse 'reais' no singular?", se alguém puder me ensinar uma condição para fazer isso eu agradeço :)

 

algoritmo "Troco"
var
   preco, dinheiro, troco, resto : real
   quantidade : inteiro

inicio
   escreva("Digite o preço unitário: ")
   leia(preco)

   escreva("Quantidade comprada: ")
   leia(quantidade)

   escreva("Dinheiro recebido: ")
   leia(dinheiro)

   se dinheiro >= (preco * quantidade) entao
      troco <- dinheiro - (preco * quantidade)
      escreval("Troco = ", troco:4:2)
   senao
      resto <- (preco * quantidade) - dinheiro
      escreval("Dinheiro insuficiente. Faltam ", resto:4:2, " Reais")
   fimse
fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

Olá@Kaiza

 

Existem tantas outras condicionais em sua programação e essa é só mais uma que vai após escrever o resto.
 

Em 21/01/2022 às 21:14, Kaiza disse:
escreval("Dinheiro insuficiente. Faltam ", resto:4:2)

 

Bem aqui escreva a condicional para verificar a necessidade de plural, no caso se resto é maior que 1 então é plural.

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

  • Moderador

@Kaiza, alguns pontos:
- a moeda é escrita em minúsculo mesmo. Usar "reais" em vez de "Reais";
- o verbo "faltar" também precisaria ser flexionado. Ex.: "Falta 1 real" ou "Faltam 15 reais".

 

 

Alguns exemplos:


Utilizando um texto genérico:

   se dinheiro >= (preco * quantidade) entao
      troco <- dinheiro - (preco * quantidade)
      escreval("Troco = ", troco:1:2, "real(is)")
   senao
      resto <- (preco * quantidade) - dinheiro
      escreval("Dinheiro insuficiente. Falta(m) ", resto:1:2, " real(is)")
   fimse




Utilizando R$:

   se dinheiro >= (preco * quantidade) entao
      troco <- dinheiro - (preco * quantidade)
      escreval("Troco = R$ ", troco:1:2)
   senao
      resto <- (preco * quantidade) - dinheiro
      escreval("Dinheiro insuficiente. Falta(m) R$", resto:1:2)
   fimse

 


Utilizando condicional:

   senao
      resto <- (preco * quantidade) - dinheiro
      se (resto = 1) entao
         escreval("Dinheiro insuficiente. Falta ", resto:1:2, " real")
      senao
         escreval("Dinheiro insuficiente. Faltam ", resto:1:2, " reais")
      fimse
   fimse

 

  • Amei 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como ganhar dinheiro montando computadores!

MINICURSO GRÁTIS!

Como ganhar dinheiro montando computadores!

CLIQUE AQUI E INSCREVA-SE AGORA MESMO!