×
Ir ao conteúdo
  • Cadastre-se

VisualG "Esperava encontrar entao" sendo q já tem "entao" no Visualg


Ir à solução Resolvido por Simon Viegas,

Posts recomendados

Algoritmo "semnome"

tipo cadastroCliente = registro

   nome: caractere
   rg: caractere
   idade: inteiro
fimregistro

Var
   i: inteiro
   clientes : cadastroCliente
   opcao: caractere
   rgPesquisa: caractere
Inicio
   repita
      escreval ("1- Cadastrar")
      escreval ("2- Pesquisar")
      escreval ("3- Sair")
      leia (opcao)

      se opcao = "1" entao
         para i de 1 ate 3 faca
            se clientes[i] = " " entao
               Escreval ("Digite seu nome: ")
               leia (clientes.nome)
               Escreval ("Digite seu rg: ")
               leia (clientes.rg)
               Escreval ("Digite sua idade: ")
               leia (clientes.idade)
               interrompa
            fimse
         fimpara
      senao
         se opcao = "2" entao
            Escreval ("Digite o RG: ")
            leia (rgPesquisa)
            para i de 1 ate 3 faca
               se clientes[i].rg = rgPesquisa entao
                  escreval ("Cliente ", clientes[i].nome, " encontrado."
                  interrompa
               fimse
            fimpara
         fimse

      ate opcao = "3"

Fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

  • Moderador
  • Solução

@CaioSan, faltou declarar o vetor lá nas variáveis. Algo como:

 

clientes : vetor[1..3] de cadastroCliente

 


Declarou:

10 minutos atrás, CaioSan disse:
Var
   ...
   clientes : cadastroCliente

 


Aí o VisualG apresenta problemas! 😁


Observe que o tipo é apenas "um registro", não um "vetor de registro", logo, lá no se onde deu erro não poderia ter os [].

Adendo: no VisualG não dá para definir um tipo "vetor de registros". Infelizmente. (No Pascal, pai do VisualG dá.)

  • Amei 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!