×
Ir ao conteúdo
  • Cadastre-se

VisualG Criar função/procedimento e vetores


Posts recomendados

Escreva um pseudocódigo (algoritmo) que receba as informações do pedido. Esses pedidos devem entrarem uma fila de produção e serem retirados da fila quando forem atendidos. Construa um menu, para que a atendente possa escolher a operação que deseja executar:###### LANCHONETE####### 1 –INCLUIR PEDIDO ## 2 -ATENDER PEDIDO ## 3 -LISTAR PEDIDOS ## 4–PESQUISARPEDIDO## 5–ENCERRAR#########################Construa as funções ou procedimentos necessários para cada item do menu. Utilize um vetor de 10 posições para registrar os pedidos. Não permita que o usuário encerre o programa (opção ENCERRAR) se ainda existirem pedidos para serem atendidos e ao encerrar o programa, informe ao usuário o faturamento total(soma de todos os valores dos pedidos) e a quantidade pedidos que foram atendidos. Observação: Implemente as mensagens de “ListaVazia–Não Existem Pedidos” e “Fila Cheia–Não Pode Mais Incluir Pedidos”, quando necessário.

 

Criar o registro “rCadPedido” (tipo de dado dos pedidos), contendo os seguintes itens: número do pedido do tipo inteiro, tipo de atendimento do tipo inteiro(“1” para atendimento na loja e “2” para atendimento via delivery), nome do cliente do tipo caractere, valor total do tipo real;

 

Criar um vetor com 10 posições do tipo rCadPedido;

 

Criar uma função/procedimento Incluir Pedido. Esta função ou procedimento deve incluir um pedido no vetor. Atenção para a mensagem de lista cheia;

 

 Criar uma função/procedimento Atender Pedido. Esta função ou procedimento deve apagar o pedido mais antigo ou apenas mover o ponteiro do pedido a ser atendido, de tal forma que o algoritmo saiba que o pedido foi atendido. Atenção para a mensagem de lista vazia;

 

Criar uma função/procedimento Listar Pedidos. Esta função ou procedimento deve listar todos os pedidos que ainda não foram atendidos. Atenção para a lista vazia;

 

Criar uma função/procedimento Pesquisar Pedido. Esta função ou procedimento deve pesquisar um pedido pelo seu número e informar a posição do pedido. Caso o pedido não seja encontrado, enviar uma mensagem para o usuário que o pedido não foi encontrado. Atenção para lista vazia;

 

Criar uma função/procedimento Encerrar. Esta função ou procedimento deve encerrar o algoritmo apenas se não existirem pedidos para ser atendidos. Caso ainda existam pedidos, uma mensagem deve ser enviada ao usuário e o algoritmo não deve ser finalizado.

Link para o comentário
Compartilhar em outros sites

  • Moderador

Caro usuário,

 

Seja bem-vindo ao Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

 

Link para o comentário
Compartilhar em outros sites

  • DiF alterou o título para Criar função/procedimento e vetores
Algoritmo "Lanchonete"
Const
   max = 10

tipo
   rCadPedido = registro

      nome :caractere
      pedido :caractere

   fimregistro


funcao finserir (pos_lista : inteiro) : inteiro
inicio
   pos_lista := pos_lista + 1
   se pos_Lista > max entao
      pos_lista := pos_lista - 1
      escreval ("Lista Cheia!!!")
   senao
      escreva ("Informe o Nome do Cliente: ")
      leia (Vpedido[pos_lista].Nome)
   fimse
   retorne pos_lista
fimfuncao

procedimento plistar (pos_lista : inteiro)
var
   ind : inteiro
inicio
   se pos_lista = 0 entao
      escreval ("Fila Vazia!!!")
   senao
      para ind de 1 ate pos_lista faca
         escreval (ind,"º Cliente:", Vpedido[ind].Nome," Pedido: ",Vpedido[ind].pedido)
      fimpara
   fimse
fimprocedimento

Var
   opcao , NumPed :inteiro
   ValTotal :real
   Vpedido  :vetor [1...max] de  rCadPedido
Inicio


     pfim := 0
   Repita
      limpatela
      escreval ("##########################")
      escreval ("*******LANCHONETE******")
      escreval ("# 1 - INCLUIR PEDIDO  #")
      escreval ("# 2 – ATENDER PEDIDO   #")
      escreval ("# 3 – LISTAR PEDIDO   #")
      escreval ("# 4 – PESQUISAR PEDIDO  #")
      escreval ("# 0 - ENCERRAR     #")
      escreval ("##########################")
      escreval ("")
      escreva  ("Informe a opção desejada: ")
      leia (opcao)
      escolha opcao
      caso 0
         escreval ("")
         escreval ("Finalizando...")
         escreval ("")
      caso 1
         pfim := finserir(pfim)
         leia(pause)
      caso 2
         plistar(pfim)
         leia(pause)
      caso 3

         leia(pause)
      caso 4
         leia(pause)
      outrocaso
         escreval ("")
         escreval ("Opção inválida!!!")
         escreval ("")
         leia(pause)
      fimescolha
   ate opcao = 0

Fimalgoritmo


Sintaxe incorreta na declaração de variáveis.

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!