Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Rudá

Dominio

Recommended Posts

No servidor o dominio ficou dominio.com.br

e o site que ta no ar é dominio.com.br

Então quando vou tentar acessar na dominio.com.br na empresa ele não encontra porque ele ta pesquisando o servidor e tem que acessar o site

Como resolver o problema??

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cheque as configurações de DNS do servidor. No dns deve constar, a grosso modo, qual o endereço IP de dominio.com.br.

qualquer coisa, seja mais específico em relação ao seu problema que a gente tenta ajudar.

ARN1972

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vou explicar melhor, Tenho um servidor Windows 2003 Server com o dominio dominio.com.br, e tenho o site na internet que é o mesmo nome dominio.com.br, então não consigo acessar o meu site que ele da conflito.

Quando entro no IE e coloco dominio.com.br ele tenta achar no meu servidor, mas ele tem que procurar o site o externo que está hospedado em um servidor.

Ex: Temos o site empresa.com.br ai esse site é hospedado em um host qualquer, ai a empresa vai e coloca o servidor para gerenciar a rede da empresa e coloca o dominio como empresa.com.br e com isso da conflito.

Entendeu????

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado Originalmente por Rudá@23 de janeiro de 2006, 00:43

Entendeu????

Entendi !!!!!!

Acredito que o problema continue sendo com DNS. As estações simplesmente não sabem onde localizar a página www.dominio.com.br. Vá no servidor, abra o DNS e adicione um novo host www com o ip de www.dominio.com.br (site externo). Se preferir, edite o arquivo LMHOSTS de todas as estações de trabalho/ servidor e adicione a entrada para o site externo.

Pode ser necessário reiniciar as estações ou executar o comando ipconfig /flushdns para limpar o cache do dns.

Bom, como já disse anteriormente, mande mais informações que a gente tenta ajudar.

Boa sorte,

ARN1972

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado Originalmente por Rudá@24 de janeiro de 2006, 13:16

Fiz isso só que agora aparece a página do Cpanel e não do site.

www.cpanel.com? Esta é a página que abre? Cara, que coisa estranha. Topa fazer alguns testes? Coloca o ip de um site conhecido (200.221.2.45 - uol) como sendo o ip de www.dominio.com.br. Faça um teste e veja se abre a página do UOL. Em sua rede interna, através do navegador, digite http://ipdosite . Veja se a página abre corretamente (terá que abrir a página principal de www.dominio.com.br). Faça os testes e me mande uma resposta. O problema, com certeza está com o dns. Resta descobrir em que ponto está o erro. qualquer coisa mande uma mensagem privada com mais detalhes e se possível, com as fotos do erros que estão ocorrendo e da configuração do dns.

Aguardando,

ARN1972

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não abre o site do cpanel, abre a página do servidor de linux que usa o programa cpanel para configurar os dominios, aparece a mensagem de site não configurado.

Aparece +- essa página http://72.232.15.155 só que com a mensagem de site não configurado.

Já que para acessar o site pelo ip tem que ser

http://72.232.15.155/~hyper

E em outros lugares entra normalmente os dns estão corretos.

https://registro.br/cgi-bin/nicbr/whois?qr=hiperleao.com.br

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Rudá

Acho que estamos cada vez mais próximos da solução. Pelas informações que você me passou no último post, o problema deve estar no servidor linux. Veja o motivo:

- Você deve estar usando o servidor apache com o recurso virtual host name based ativo. Com isso, você pode hospedar diversas páginas web em um único endereço IP.

A configuração é feita através do arquivo httpd.conf e acredito que deva ficar parecido com isso:

<72.232.15.155:8080>

ServerName www.hiperleao.com.br

DocumentRoot /~hyper

</VirtualHost>

Veja esse tutorial sobre apache para obter mais informações.

Acredito que seu problema esteja na configuração do documentroot (local onde estaria armazenada a página do site), já que o servidor apache não sabe para qual diretório direcionar as requisições. Por isso que quando você utiliza http://72.232.15.155/~hyper ou http://www.hiperleao.com.br/~hyper a página abre perfeitamente.

Dê uma olhada nisso, e avise assim que funcionar. Agora acho que vai dar tudo certo.

ARN1972

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado Originalmente por Rudá@29 de janeiro de 2006, 17:43

Então vou ter que abrir http://www.hiperleao.com.br/~hyper ???

Não tem outro jeito de configurar??

Não, Rudá. Olha o que está acontecendo. O usuário digita o site do hiperleao em seu navegador web. O navegador web vai consultar um servidor dns para saber qual o ip do hiperleao. Uma vez descoberto, ele vai até o servidor apache e fala que quer abrir a página do site. O servidor apache sabe que hospeda o site, mas não sabe qual a pasta base onde estão armazenados os arquivos do site. Por isso, ao utilizar http://www.hiperleao.com.br/~hyper funciona. A informação que falta ao servidor web é a /~hyper.

Em meu último post, há um totorial sobre o servidor apache. Leia com atenção que você vai entender o problema e vai saber resolvê-lo. Veja as configurações do httpd.conf:

<72.232.15.155:8080> ---> IP e a porta que o servidor deve ficar ouvindo

ServerName www.hiperleao.com.br --> O nome do site

DocumentRoot /~hyper --> A pasta base que o usuário deve ser direcionado.

</VirtualHost>

Como já foi testado anteriormente ( http://72.232.15.155/~hyper ou http://www.hiperleao.com.br/~hyper) não há problemas com a primeira e segunda linhas. O problema está na terceira linha. Faça esse acerto, nem que seja através de um editor de texto do Linux e acredito que o servidor funcionará sem problemas. Com isso, irá funcionar perfeitamente o endereço www.hiperleao.com.br.

ARn1972

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

Primeiro uma dica...

Não se cria dominios locais iguais aos externos, isso só causa dores de cabeça e aborrecimentos...

Minha sugestão?

Abaixe o servidor e recrie, se for algo simples, do contrário a melhor solução é criar um REDIRECIONAMENTO dentro das configurações do DNS para o ip do servidor DNS externo, ou para o ip de onde estiver hospedado o site, ip EXTERNO.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Primeiro uma dica...

Não se cria dominios locais iguais aos externos, isso só causa dores de cabeça e aborrecimentos...

Minha sugestão?

Abaixe o servidor e recrie, se for algo simples, do contrário a melhor solução é criar um REDIRECIONAMENTO dentro das configurações do DNS para o ip do servidor DNS externo, ou para o ip de onde estiver hospedado o site, ip EXTERNO.

Exatamente, vocé teria que criar um domínio por exemplo hiperleao.local e não hiperleao.com.br, ai você tem uma série de problemas como esse:(

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×