Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Virus

Ubuntu to Kubuntu 5.10, como alterar a resolução?

Recommended Posts

Instalei o ubuntu aqui em casa e gostei muito, exceto pelo GNOME, procurei e encontrei como atualizar para Kubuntu via APT com KDE 3.5... Durante a instalação ele não fez teste de vídeo (não tem) e setou minha resolução para 1024x768, pra mim é absurdo de grande, estou acostumado com 1280x1024, que era a resolução que usava no Conectiva 10 e no Fedora Core 4... Fui ao arquivo de configuração xorg.conf e adicionei a resolução que eu queria, foi o mesmo que se eu não tivesse mexido em nada... E quero o mais rápido possível mudar a resolução, mas não consigo... Qualquer tentativa de ajuda é válida.

Meu xorg.conf:


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
       # paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver  "kbd"
Option  "CoreKeyboard"
Option  "XkbRules" "xorg"
Option  "XkbModel" "pc104"
Option  "XkbLayout" "us"
Option  "XkbVariant" "intl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver  "mouse"
Option  "CorePointer"
Option  "Device"  "/dev/input/mice"
Option  "Protocol"  "ImPS/2"
Option  "Emulate3Buttons" "true"
Option  "ZAxisMapping"  "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
Driver  "nv"
BusID  "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option  "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device  "NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
Monitor  "Generic Monitor"
DefaultDepth 24
SubSection "Display"
 Depth  1
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  4
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  8
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  15
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  16
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  24
 Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen  "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Edit: Me desculpem pelo engano, estava mexendo no source.list e acabei postando por engano... Já corrigi.

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vírus, você cometeu um erro. Este não é seu arquivo Xorg.conf nem de longe... O arquivo fica em /etc/X11/Xorg.conf. Verifique e poste ele aqui por inteiro. Vai ficar grande mesmo, mas é mais fácil pra entender.

Falou

OBS.: Não posto o meu porque por estar indispónível no momento.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Hawker Hurricane AII me desculpe, postei o arquivo errado mas já corrigi... Cabeça cheia hoje e com essa aparência que ocupa meu desk todo... Bom coloquei um PS em negrito...

t+

PS: Sempre achei o flash plugin tão simples de colocar...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara, eu não sei se vai te ajudar, eu uso o suse 9.3 e analisei o xorg.conf da minha configuração e notei q exitem algumas linhas no meu codigo q não existem no seu, talvez isso possa ajudar se você fizer a config correta (as linhas q notei no meu arquivo estão marcados com >>).

Section "Monitor"

DisplaySize 280 210

HorizSync 31-48

Identifier "Monitor[0]"

ModelName "SYNCMASTER 4S"

Option "DPMS"

VendorName "SAMSUNG"

VertRefresh 43-75

>> UseModes "Modes[0]"

EndSection

Section "Modes"

>> Identifier "Modes[0]"

>> Modeline "1024x768" 63.04 1024 1080 1184 1344 768 769 772 795

Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626

Modeline "640x480" 29.84 640 664 728 816 480 481 484 501

EndSection

Section "Device"

BoardName "ProSavage DDR-K"

BusID "1:0:0"

Driver "savage"

Identifier "Device[0]"

VendorName "S3"

EndSection

Section "Screen"

DefaultDepth 16

SubSection "Display"

Depth 15

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 32

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "800x600" "640x480"

EndSubSection

Device "Device[0]"

Identifier "Screen[0]"

Monitor "Monitor[0]"

EndSection

_________

ve se modificando alguma coisa no teu arquivo isto possa te ajudar. talvez o valor UserModes precise ser definido por você. Desculpa se não ajudei.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Section "Screen"

Identifier "Default Screen"

Device  "NVIDIA Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR]"

Monitor  "Generic Monitor"

DefaultDepth 24

SubSection "Display"

Depth  1

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth  4

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth  8

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth  15

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth  16

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth  24

Modes  "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

EndSection

Veja em negrito. Há o DefaultDepth, que é a resolução a ser usada. Repare que está setado pra ser 24 o padrão. Então na linha do 24 temos os seguintes modos:

"1024x768" "832x624" "800x600" "720x400" "640x480"

Se não me engano basta adicionar a resolução desejada, lembrando que isto serve apenas pra definir a resolução máxima. Depois de setado isto talvez você tenha que alterar a resolução já dentro do ambiente gráfico também. Ex.:

"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"

Bom, é isto.

OBS.: Sabe instalar o plugin flash pra Ubuntu 64 bits? Porque a própria Macromedia ainda não disponibilizou o pacote. Sei que dá pra instalar, mas tem que fazer uma baita duma mão de obra. Se tu conseguiu, me explica por favor, lembrando que é pra 64.

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tem que ficar usando chroot no linux de 64bits... Achei que você estava falando do linux de 32 bits... Vou procurar saber pra você não ficar sem usar se quiser...

t+

Compartilhar este post


Link para o post
Compartilhar em outros sites

estava olhando aqui e vi q meu xorg.conf ta assim:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
       # paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver  "kbd"
Option  "CoreKeyboard"
Option  "XkbRules" "xorg"
Option  "XkbModel" "abnt2"
Option  "XkbLayout" "br"
Option  "XkbVariant" "abnt2"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver  "mouse"
Option  "CorePointer"
Option  "Device"  "/dev/input/mice"
Option  "Protocol"  "ImPS/2"
Option  "Emulate3Buttons" "true"
Option  "ZAxisMapping"  "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
Driver  "nv"
BusID  "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "SyncMaster"
Option  "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device  "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
Monitor  "SyncMaster"
DefaultDepth 24
SubSection "Display"
 Depth  1
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  4
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  8
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  15
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  16
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
 Depth  24
 Modes  "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen  "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Apesar dele mostrar 1152x864 ali eu não tenho essa opção p escoler. Se eu mexer em algum lugar da p mudar isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu so copiei/colei o xorg.conf mesmo, não mexi em nada. O monitor é d 15", mas já me disseram que conseguiram botar mais q 1024x768 c um desse.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Hawker Hurricane AII esse "1280x1024" foi a primeira coisa que tentei... :(

antonypeople onde posso ver isso, atrás do meu monitor não diz... Mas o modelo dele é Philips CM4018D1 de 17".

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não encontrei nada no site da philips e quando comprei não veio manual e na época nem me preocupei....

Edit: Hawker Hurricane AII uma dica pra você instalar o flash, a fonte é esta

Para aqueles usando processadores 64-bit (ou Mac) não existe implementação flash não-livre disponível porque o desenvolvedor não dá suporte a eles. No entato, há duas implementações livres. Uma é o gplflash e a outra é o swfdec. Ainda existe o gplflash2 em desenvolvimento que visa ser o livre ideal, uma reposição em código livre para todas as plataformas. Embora você pode instalá-los usando o apt-get, eles costumam não funcionar muito bem e são instáveis, então a opção não é das melhores. É melhor instalar um deles (eu recomendo o gplflash) manualmente.

Para instalar o gplflash:

Baixe a última versão do gplflash (enquanto eu escrevo é a 0.4.13) do link [WWW] https://sourceforge.net/project/showfiles.p...group_id=110956.

$ wget -c [url]http://prdownloads.sourceforge.net/gplflash/gplflash-0.4.13.tar.bz2?download[/url]

Você deve baixar a última versão se não for a 0.4.13. Descompacte os arquivos.

$ tar xvjf gplflash-0.4.13.tar.bz2

Instale os pacotes necessários para construir o gplflash.

$ sudo apt-get install build-essential libjpeg62-dev zlib1g-dev xlibs-dev libmad0-dev checkinstall

Vá para o diretório de instalação.

$ cd gplflash-0.4.13

Compile o player e o plugin, então chame o checkinstall para criar um arquivo deb.

$ ./configure --prefix=/usr --with-plugin-dir=/usr/lib/mozilla-firefox/plugins/
$ make
$ sudo checkinstall

Quando o checkinstall lhe mostrar uma situação geral, certifique-se de ajustar a opção 7 (Arquitetura) para amd64 ao invés de x86_64. Então aperte Enter para construir e instalar o gplflash-0.4.13_0.4.13-1_amd64.deb. Abra o Mozilla ou o Firefox e aproveite!

PS: Resolvi meu problema com a resolução do monitor...

:D

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×