Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
olliver.soul

Missão quase impossível – gDesklets

Recommended Posts

Pessoal, essa é difícil.

Estou tentando instalar o gDesklets (já tentei o 0.35 e o 0.34) e mesmo depois de uma romaria atrás das dependências, e muito trabalho pra compilar, o "cara" num roda! :muro: Já compilei umas três vezes só para me certificar se dá algum erro durante a instalação, mas a instalação é processada com sucesso.

Quando entro com o comando $ gdesklets start, é retornado o seguinte erro:

Conectando ao servidor [## ] You need a recent version of PyGTK to run this program

Cannot establish connection to daemon: timeout!

Por que ocorre este erro? mesmo depois de eu ter instalado TODAS AS DEPENDNCIAS? (pygtk 2.8.4, gtk+ 2.8.9...) ?? :tantan:

Já pesquisei muito a respeito, mas não consegui encontrar nada que resolva o problema.

Se alguém já passou por esse problema e tem alguma dica mesmo que pareça meio óbvio, por favor, me ajudem a resolver esse problema. :help:

# ----------------

RedHat 9.0

Athlon XP 2000

RAM 256 MB

Compartilhar este post


Link para o post
Compartilhar em outros sites

Isso geralmente acontece quando as distros Debian-like vai tentar compilar alguns programas. Ela não compila porque a distro não tem as libs nescesarias. Eu não entendo muito sobre o redhat, ele tem apt-get ? pode ser que o red hat não seja uma boa distro para compilar coisas. uma excelente distro pra compilações é o SLACKWARE. Tente procurar o pacote binario do gdesklets

Compartilhar este post


Link para o post
Compartilhar em outros sites

Qualqueer distro é excelente para compilações se instalados os pacotes necessarios... o Red Hat não usa o sistema APT (nem .deb e sim .rpm), alias, o último Red Hat lançado para download foi o 9.0, a partir dai só o Fedora Core, qual a sua versão?

Neste caso ele está pedindo o PyGTK (GTK+ for Python) mais recente... tente conseguir o pacote no site deles...

T+

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mais eu instalei PyGTK 2.8.4, que é ultima versão.

antonypeople:

Estou usando o Red Hat 9.0, já testei o Conectiva, Fedora e outras distribuições. Mas o Red Hat foi o que eu mais gostei, só que eu num gosto de instalar programas como os pacotes rpm, baixar o fonte e compilar é o que eu mais gosto de fazer. :joia:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Neste caso, por ser uma distro antiga (ainda lembro que usei esta versão antes de baixar meu Slackware 9.1), ela pode estar com problemas de dependências mais complicadas. Você instalou o PyGTK direitinho, não deu nenhum erro de compilação e/ou dependência? Sei que instalar a partir dos fontes é bem mais divertido, e resolver os problemas é bem desafiador, mas teste instalar o rpm do pacote para ver se dá certo... só para testes... depois você continua a partir dos fontes... todas as possibilidades precisam ser observadas.

T+

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×