Ir ao conteúdo
  • Cadastre-se
Viníciusnit

IE: "Clique aqui para ativar e usar esse controle"

Posts recomendados

Olá!

Vocês poderiam me ajudar a desativar a proteção no Internet Explorer em animações Flash e em vídeos incluídos em alguma página?

Essa proteção consiste em não permitir o manuseio do Flash e/ou do vídeo enquanto não for clicado em cima do mesmo. Ao manter o mouse em cima aparece o seguinte aviso: "Clique aqui para ativar e usar esse controle".

Formatei o PC ontem e a partir de hoje começou a aparecer isso. Acho que foi alguma atualização feita que acabou criando essa "característica" nova no Internet Explorer.

Alguém sabe o que está causando isso? Isso tá acontecendo com vocês também?

Abraços!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Isso é devido a uma patente que a Eolas tem a Microsoft perdeu na justiça. Como a Microsoft não quer licenciar a patente da Eolas (porque muita gente acha que ela é inválida), a MS teve que alterar o IE.

A Microsoft disponibiliza um patch temporário pra desativar isso, mas não adianta muito, porque vai ser obrigatório depois de Junho.

Se você é desenvolvedor web, vai ter que ajustar as páginas de acordo com as instruções da Microsoft:

http://msdn.microsoft.com/library/default....ing_activex.asp

Compartilhar este post


Link para o post
Compartilhar em outros sites

Apenas desativar as opções de multimida na aba Avançadas das opções da internet não audaria?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado Originalmente por FallenHawk@12 de abril de 2006, 16:04

Isso é devido a uma patente que a Eolas tem a Microsoft perdeu na justiça. Como a Microsoft não quer licenciar a patente da Eolas (porque muita gente acha que ela é inválida), a MS teve que alterar o IE.

A Microsoft disponibiliza um patch temporário pra desativar isso, mas não adianta muito, porque vai ser obrigatório depois de Junho.

Se você é desenvolvedor web, vai ter que ajustar as páginas de acordo com as instruções da Microsoft:

http://msdn.microsoft.com/library/default....ing_activex.asp

Poxa, muito obrigado pela resposta e esclarecimento!

Me desculpe pela falta de conhecimento no assunto, mas você poderia me explicar o que seria "Eolas"? Nunca tinha ouvido falar sobre isso, ou não estou lembrado. Fiquei curioso e queria entender o que aconteceu/está acontecendo.

Abraços!

=======================

Editando:

Eu li uma EXCELENTE matéria do "IDG Now" que explica o que aconteceu detalhadamente e agora entendi melhor o que houve. A matéria está aqui: http://idgnow.uol.com.br/computacao_pessoa...IDGNoticia_view

E sobre o patch no qual você se referiu, onde posso baixá-lo?

Obrigado mais uma vez!

Postado Originalmente por bruno_fa85@12 de abril de 2006, 16:18

Apenas desativar as opções de multimida na aba Avançadas das opções da internet não audaria?

Acho que não, já que se trata de uma alteração global no programa feita pela própria Microsoft.

Valeu pela resposta!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se alguém souber uma forma simples de desativar este novo problema na navegação para quem é desenvolvedor, eu agradeceria.

: )

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olha como eu fiz para resolver o problema

Primeiro você deve criar um arquivo .js e colocar o seguinte codigo nele:

//Chama flash no site (correção do IE)

function exibeFash(swf, width, height, wmode, cache)

{

noCache = cache || cache == undefined ? "" : "?" + new Date();

wmode = wmode || wmode == undefined ? "opaque" : "transparent";

monta_swf = "";

monta_swf += "<object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0\" width=\""+ width +"\" height=\""+ height +"\" title=\"\">";

monta_swf += "<param name=\"movie\" value=\""+ swf + noCache +"\" />";

monta_swf += "<param name=\"quality\" value=\"high\" />";

monta_swf += "<param name=\"menu\" value=\"0\" />";

monta_swf += "<param name=\"wmode\" value=\""+ wmode +"\" />";

monta_swf += "<embed src=\""+ swf + noCache +"\" quality=\"high\" wmode=\""+ wmode +"\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\" type=\"application/x-shockwave-flash\" width=\""+ width +"\" height=\""+ height +"\"></embed>";

monta_swf += "</object>";

document.write(monta_swf);

}

Atenção, não adianta colocar o conteudo acima diretamente na página que ira exibir o arquivo swf que não funciona.

Digamos que você criou um arquivo chamado funcao.js.

na página que ira exibir o arquivo swf você deve fazer a chamada para esse arquivo:

<script language="javascript" funcao.js"></script>

e no local onde deve exibir o arquivo swf você coloca o seguinte script:

<script>exibeFash('arquivo.swf', 225, 109)</SCRIPT>

Mastigadinho... Funciona perfeitamente.

Um abraço

Alex Adriano

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, obrigado pela dica, funcionou perfeitamente, agora eu não estou conseguindo

deixar o objeto na base da janela (alinhado a base) antes quando eu tinha funcionava

perfeitamente no firefox mas no IEca nunca funcionou wacko.gif , vou explicar melhor tenho uma animação

inicial na minha pagina em flash, e eu gostaria que ela funcionasse na base do navegador o meu flash

tem 100% de largura por 360 de altura.

aguardo alguma ajuda aí...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá

O código acima funciona, mas acho ele mais "chato" de implementar. tem uma maneira mais prática:

Insira o arquivo flash no Dreamweaver como de costume e copie o código do flash, ou seja tudo entre as tags: <OBJECT>...</OBJECT>.

Aí você cria um novo arquivo .js e cola esse código nele. Vamos dizer que o nosso código do flash seria este:


<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,24,0" width="125" height="110" title="teste">
              <param name="movie" value="teste.swf" />
              <param name="quality" value="high" />
              <param name="menu" value="false" />
              <param name="wmode" value="transparent" />
              <embed src="teste.swf" width="125" height="110" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false" wmode="transparent"></embed>
            </object>

Então no arquivo .js você adicionaria na frente de cada linha do código:

document.write('

e no final da linha:

);

Então nosso código reescrito ficaria assim:


document.write('<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,24,0" width="125" height="110" title="teste">');
document.write('              <param name="movie" value="teste.swf" />');
document.write('              <param name="quality" value="high" />');
document.write('              <param name="menu" value="false" />');
document.write('              <param name="wmode" value="transparent" />');
document.write('              <embed src="teste.swf" width="125" height="110" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false" wmode="transparent"></embed>');
document.write('            </object>');

Aí você salva o arquivo com a extensão .js (neste exemplo eu salvaria como "teste.js") e no lugar onde você colocar o flash na página você simplesmente insere:

<script src="teste.js"></script>

Simples assim. Sem precisar ficar inserindo esse tanto de código a mais do outro exemplo. :palmas:

Um abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Alguém pode me ajudar?

Quando faço down na IE "Salvar destino como" ele me diz que a configuração foi alterada e dependendo da pagina ele não abre a 2* pagina o que faço?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Postei aqui há um tempo atras como retirar esse problema mas agora a Microsoft tornou obrigátorio esse patch de atualização ou seja para retirar somente da seguinte forma Inciar > Configurações > Painel de Controle > Adcionar ou Remover Programas > Procurem (KB916281) e desinstalem Obs: se não estiverem conseguindo ver, Acima na janela cliquem em "Exibir Atualizações"

MAS ATENÇÃO SE voce DEIXA O WINDOWS UPDATE NO AUTOMATICO, FAÇA O SEGUINTE APOS DESISTALAREM O (KB916281) VÁ EM INICAR > CONFIGURAÇÕES > PAINEL DE CONTROLE > ATUALIZAÇÕES AUTOMATICAS > SELECIONE "Avisar, mas não fazer download nem instalá-las automaticamente" FEITO ISSO CLIQUE EM OK.

REINICIE O COMPUTADOR DEPENDENDO DA VELOCIDADE DE SUA CONEXAO LOGO APARECERÁ DO LADO DO RELOGIO A mensagem "As atualizações estão prontas, clique aqui para baixa-las e instala-las" CLIQUE NA NOTIFICAÇÃO IRÁ APARECER UMA CAIXA DE DIALOGO ONDE ESTA´RA SELECIONADO AUTOMATICAMENTE "Atualização de segurança cumulativa para o Internet Explorer para Windows XP (KB916281)" DESMARQUE A CAIXA E DEPOIS CLIQUE EM FECHAR, EM SEGUIDA SURGIRÁ A MENSAGEM AS ATUALIZAÇÕES SEGUINTES NÃO SERAO INSTALADAS....

IMPORTANTE QUE voce MARQUE A CAIXA "NÃO ME AVISAR MAIS SOBRE ESSAS ATUALIZAÇÕES"

APOS ISSO ATIVE AS ATUALIZAÇOES AUTOMATICAS. não SE PREOCUPE QUE A ATUALIZAÇÃO (KB916281) não VOLTARÁ. PARA VE-LA SOMENTE EM INCIAR > WINDOWS UPDARTE E CLICAR EM "Revisar atualizações ocultas"

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ver so. Meu IE não ta abrindo algumas paginas de umas semanas pra ca. você clica no link, mas ao abrir, fica em branco e aparece concluido. Sera q é essa frescura q ta aparecendo (uma das...)? Sabem como resolvi esse pro?Instalei o Mozila Firefox e to usando file...

Compartilhar este post


Link para o post
Compartilhar em outros sites

É simples! Basta ter o DreamWeaver 8 instalado e atualizá-lo pela adobe:

VEJA AQUI

Ai toda a vez que você inserir um Flash em sua página o dreamweaver automaticamente vai gerar um JS para contornar o problema do Microsoft-IE...

IntÉ! :priv:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Postei aqui há um tempo atras como retirar esse problema mas agora a Microsoft tornou obrigátorio esse patch de atualização ou seja para retirar somente da seguinte forma Inciar > Configurações > Painel de Controle > Adcionar ou Remover Programas > Procurem (KB916281) e desinstalem Obs: se não estiverem conseguindo ver, Acima na janela cliquem em "Exibir Atualizações"

MAS ATENÇÃO SE voce DEIXA O WINDOWS UPDATE NO AUTOMATICO, FAÇA O SEGUINTE APOS DESISTALAREM O (KB916281) VÁ EM INICAR > CONFIGURAÇÕES > PAINEL DE CONTROLE > ATUALIZAÇÕES AUTOMATICAS > SELECIONE "Avisar, mas não fazer download nem instalá-las automaticamente" FEITO ISSO CLIQUE EM OK.

REINICIE O COMPUTADOR DEPENDENDO DA VELOCIDADE DE SUA CONEXAO LOGO APARECERÁ DO LADO DO RELOGIO A mensagem "As atualizações estão prontas, clique aqui para baixa-las e instala-las" CLIQUE NA NOTIFICAÇÃO IRÁ APARECER UMA CAIXA DE DIALOGO ONDE ESTA´RA SELECIONADO AUTOMATICAMENTE "Atualização de segurança cumulativa para o Internet Explorer para Windows XP (KB916281)" DESMARQUE A CAIXA E DEPOIS CLIQUE EM FECHAR, EM SEGUIDA SURGIRÁ A MENSAGEM AS ATUALIZAÇÕES SEGUINTES NÃO SERAO INSTALADAS....

IMPORTANTE QUE voce MARQUE A CAIXA "NÃO ME AVISAR MAIS SOBRE ESSAS ATUALIZAÇÕES"

APOS ISSO ATIVE AS ATUALIZAÇOES AUTOMATICAS. não SE PREOCUPE QUE A ATUALIZAÇÃO (KB916281) não VOLTARÁ. PARA VE-LA SOMENTE EM INCIAR > WINDOWS UPDARTE E CLICAR EM "Revisar atualizações ocultas"

aqui n deu certo :S

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá

Eu tamém tentei fazer o site pelo dreamweaver e quando fui testar deu certo, mas quando publiquei o site simplesmente as animações não apareceram...o pior é q desde hoje de manhã q eu estou tentando colocar os botoues que fiz no flash na minha página sem q apareça aquele contorno e aquela msg, se alguém tiver uma dica eu agradeço...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quando tento instalar o Macromedia Flash Player dá esse erro

Me ajudem por favor

post-15748-13884942099105_thumb.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá pessoal tudo bem??? estou com um probleminha aqui no meu PC eu instalei o windows XP ai depois atualizei o IE 6 pra o IE 7... ai quando eu vou instalar o flash q alguns sites pedem ta dando erro... ja desinstalei o IE 7 voltei pro IE 6 mas não deu jeito! O QUE FAÇO?? Alguem pode me ajudar? FICAREI GRATO! BOM INÍCIO DE ANO A TODOS!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal,

Procurei que nem um louco esta atualização: KB916281 e não encontrei...

Tô com sérias dificuldades para baixar aquivos de sites cripitografados, simplesmente eles não baixa por causa deste maledeto erro do ActiveX no IE6 tudo funcionava, agora no IE7 nada funciona..............

Alguém pode dar um help...........................................

Compartilhar este post


Link para o post
Compartilhar em outros sites

eai ??

Olha eu preciso daqueles sons do cs tipo

"cover-me' ' negative' e por ai vai

eu queria saber como eu baixo esses sons sem ter o cs instalado

Compartilhar este post


Link para o post
Compartilhar em outros sites
Pessoal,

Procurei que nem um louco esta atualização: KB916281 e não encontrei...

Tô com sérias dificuldades para baixar aquivos de sites cripitografados, simplesmente eles não baixa por causa deste maledeto erro do ActiveX no IE6 tudo funcionava, agora no IE7 nada funciona..............

Alguém pode dar um help...........................................

Pessoal,

Ninguém encontrou uma solução simples para isto?

Esta imagem condiz com um dos problemas que tenho enfrentado:

internetexplorermw6.th.jpg

Mas informo que não é só isto...

Em sites interativos que tem banco de dados e opção para exportar para por exemplo arquivo Excel, ele não consegue baixar o arquivo exatamente por isto.

Deve haver alguma forma de DESATIVAR isto.

Se alguém poder ajudar fico agradecido...

Compartilhar este post


Link para o post
Compartilhar em outros sites

O melhor conselho . . . Desinstale o IE e instale o Mozila Firefox e você nunca mais se arrependerá.

Compartilhar este post


Link para o post
Compartilhar em outros sites

bom sei que não ajuda mas.... eu não me importo de clicar no conteudo flash pra ele carregar.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu prefiro usar o Safari.

Acho ele simples e funcional.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!