Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
berma

Problema com apache

Recommended Posts

Fala galera beleza?!!

Bom primeira vez q to psotando aqui...>Espero que seja no lugar certo...Dei uma pesquisada aqui e não achei nd parecido..

Então vamos descrever td...

Tenho 2 pcs ligados no switch e ocpm um dlink500g configurado como router né..heh

instalei o Apache,Php, Myqsl e tal foi td tranquilo...do la http://localhost da a mensagem do apache q foi instalado com susse e http://localhost/index.php aparece os negocios do php tranquilo

Assim também quando do http://10.1.1.4:80/index.php vai normal também...

Só q os outros não conseguem acessar..tipo

http://meuip:80/index.php

da pagina off..

já tentei liberar a porta no modem (80)

no firewall do windows e nd..

O q devo fazer?

Bom se alguem puder me ajudar, fico grato desde já..

Valeu galera!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom descobri que a porta 80 aqui é bloqueada e tal

Então mudei no httpf do apache era assim

#Listen 12.34.56.78:80

Listen 80

Deixei assim

#Listen 12.34.56.78:80

Listen 5151

Dao do http://localhost/index.php não vai só com http://localhost:5151/index.php

Mas as outras pessoas continuam não conseguindo exergar

http://meuip:5151/index.php

já desbloqueei a porta 5151 no modem e no firewaal do xp e mesmo assim nd :(

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quanto a mudar a porta 80 isso só no caso de uma conexão externa fora da rede, ou seja um amigo seu tentando acessar seu site da casa dele...

Quando você tenta acessar pelo computador da rede interna precisa informar o IP da maquina rodando o apache, que no caso seria conforme você informou:

http://10.1.1.4:80

Certo, o pedido vai pro modem roteador, e ele não sabe pra onde mandar o pedido, é nisso que se baseia liberar a porta no modem, você tem que informar que pedidos para a porta 80 deve ser redirecionados para o ip 10.1.1.4, no protocolo TCP...

Se isso tiver certinho, tenta checar se o apache está mesmo rodando dando um localhost no navegador do pc com apache...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×