Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
nicholasbgr

Ajuda com algoritmo simples no Visualg

Recommended Posts

Olá, estou iniciando em programação e utilizando o visualg para resolver meus exercicios. Estou com um problema no seguinte exercicio:

"Dado um vetor de 50 posições, peça que o usuário insira os números, e que pergunte

para pesquisar por um valor atq que o valor digitado seja < 0. E diga se encontrou ou não e a posição."

O algoritmo que fiz já está fazendo o que o exercicio pede, mas não da forma que eu gostaria.

// Seção de Comandos

Const <- 10

Para x de 1 ate Const faca

Escreva("Atribua um valor para a posição",x,": ")

Leia(Num[x])

Fimpara

Repita

Escreva("Buscar número: ")

Leia(Busca)

Para x de 1 ate Const faca

Se Busca = Num[x] então

Escreval("Número encontrado na posição",x,".")

Senao

Escreval("Número não encontrado.")

FimSe

FimPara

Ate Busca < 0

FimRepita

fimalgoritmo

Log do programa executando:

Início da execução

Atribua um valor para a posição 1: 45

Atribua um valor para a posição 2: 65

Atribua um valor para a posição 3: 8

Atribua um valor para a posição 4: 9

Atribua um valor para a posição 5: 75

Atribua um valor para a posição 6: 4

Atribua um valor para a posição 7: 45

Atribua um valor para a posição 8: 3

Atribua um valor para a posição 9: 2

Atribua um valor para a posição 10: 5

Buscar número: 45

Número encontrado na posição 1.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número encontrado na posição 7.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Buscar número: -5

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Fim da execução.

O problema é que eu não gostaria que ele informasse "Número não encontrado." mais de uma vez, e nem quando o numero for encontrado em outra posição. Eu tenho que retirar a parte do resultado de dentro do laço, mas não sei como fazer ele informar as posições sem estar lá dentro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×