Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
nicholasbgr

Ajuda com algoritmo simples no Visualg

Recommended Posts

Olá, estou iniciando em programação e utilizando o visualg para resolver meus exercicios. Estou com um problema no seguinte exercicio:

"Dado um vetor de 50 posições, peça que o usuário insira os números, e que pergunte

para pesquisar por um valor atq que o valor digitado seja < 0. E diga se encontrou ou não e a posição."

O algoritmo que fiz já está fazendo o que o exercicio pede, mas não da forma que eu gostaria.

// Seção de Comandos

Const <- 10

Para x de 1 ate Const faca

Escreva("Atribua um valor para a posição",x,": ")

Leia(Num[x])

Fimpara

Repita

Escreva("Buscar número: ")

Leia(Busca)

Para x de 1 ate Const faca

Se Busca = Num[x] então

Escreval("Número encontrado na posição",x,".")

Senao

Escreval("Número não encontrado.")

FimSe

FimPara

Ate Busca < 0

FimRepita

fimalgoritmo

Log do programa executando:

Início da execução

Atribua um valor para a posição 1: 45

Atribua um valor para a posição 2: 65

Atribua um valor para a posição 3: 8

Atribua um valor para a posição 4: 9

Atribua um valor para a posição 5: 75

Atribua um valor para a posição 6: 4

Atribua um valor para a posição 7: 45

Atribua um valor para a posição 8: 3

Atribua um valor para a posição 9: 2

Atribua um valor para a posição 10: 5

Buscar número: 45

Número encontrado na posição 1.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número encontrado na posição 7.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Buscar número: -5

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Número não encontrado.

Fim da execução.

O problema é que eu não gostaria que ele informasse "Número não encontrado." mais de uma vez, e nem quando o numero for encontrado em outra posição. Eu tenho que retirar a parte do resultado de dentro do laço, mas não sei como fazer ele informar as posições sem estar lá dentro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×