Ir ao conteúdo
  • Cadastre-se
semmerket

Opensuse 10.3 não enxerga a rede windows

Posts recomendados

Olá galera. Instalei o Opensuse 10.3 aqui na empresa para substituir uma máquina windows xp para ser servidor de arquivos. Depois de muita luta consegui configurar o samba pra compartilhar as pastas do linux na rede windows sem que os usuários do windows precisassem entrar com o usuário e senha pra logar.

Só que uma coisa ainda não consegui fazer: é o linux reconhecer a rede windows. Ou seja, quando vou no konqueror e procuro pelos computadores windows pelo SMB:/ não acha nada. O que é mais interessante é que quando eu procuro pelo ip de uma das máquinas o linux acha e navega nela normalmente, mas só pelo ip. Ele aparentemente não está encontrando os nomes das estações, tipo vendas, suporte, etc... Só acha se for pelo ip direto, mas como as máquinas win estão configuradas com ip dinâmico, vai chegar um momento que corro o risco de não achar mais uma máquina por causa do windows ter mudado automaticamente o ip...

Receio que isso possa estar relacionado ao WINS (que é o que faz essa tradução dos IPs para os nomes), só não sei se é no Linux ou é no windows. Alguém poderia dar uma forcinha aí?

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

o seu problema provavelmente esta relacionado ao DNS (esse resolve os nomes, o WINS resolve nomes somente em NetBIOS)...

se voce digitar:

smb://192.160.x.x

voce deve setar no linux o endereço do seu servidor de DNS, para adicionar o DNS edite o arquivo /etc/resolv.conf e nele adicione:

nameserver 192.168.x.x (aqui deve ser colocado o endereço do seu servidor de DNS)

nameserver 192.168.x.x (aqui deve ser colocado o endereço do seu servidor de DNS)

ou senão vai no YAsT, nele provavelmente tem algum lugar para você configurar isso, eu não me lembro exatamente onde pois tem muito tempo que não utilizo o SuSe...

tente ai, se nao der poste ai novamente =)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá,

Eu uso o Suse 10.2 na meu micro de trabalho e consegui resolver este problema, mais ou menos como você quer, sem precisar instalar um servidor de DNS interno.

É só editar o arquivo /etc/hosts e adicionar nele os IPs seguidos dos nomes dos outros micros que existem em sua rede.

Por exemplo:

192.168.0.1 servidor

192.168.0.2 micro_1

Aqui está funcionando... e muito bem!!!!

Abraços,

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ops..

Esqueci de complementar que este esquema funcionou bem, mas as estações precisam ter endereço IP fixo.

Foi o que fizemos em nossa rede. Desativamos o DHCP e colocamos IP fixo nas estações.

Deu muito menos trabalho do que se tivessemos que instalar e configurar o BIND para isto.

Compartilhar este post


Link para o post
Compartilhar em outros sites

seabra, na verdade colocar ips manualmente nas maquinas pode ser muito mais trabalhoso...

isso porque ao formatar ou reinstalar o sistema voce tem que saber qual o IP para manter na maquina o mesmo IP, no caso do nosso amigo semmerket, talvez os passos que voce descreveu sejam uma opção melhor mesmo, mas vale resaltar que no caso de fazer isso em muitos computadores pode ser ate mais trabalhoso...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!