Ir ao conteúdo
  • Cadastre-se
alanreisdf

Excel - comparação entre colunas

Recommended Posts

A B

1

2 3

3

4 3

5

6 1

7 6

8

9 11

10

55 24

31

Gostaria de saber se há como montar algo no excel para me ajudar.

Há dados que constam na coluna "A" e também na coluna "B" e vice-versa. Porém, há dados que constam só na coluna "A" e também dados que constam só na coluna "B".

A diferença entre as duas colunas é 31. Meu objetivo é saber quais valores compuseram tal diferença.

Como são colunas pequenas, se for "matando" os valores que aparecem em ambas colunas, se retirar 45 (2, 4, 5, 7, 8, 9 e 10) da coluna "A" e retirar 14 (3 e 11) da coluna "B", consigo descobrir quais valores compuseram a diferença de 31.

Ou seja, preciso saber os valores que constam na coluna A e não constam na B e vice-versa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sinceramente não entendi o que você quer..

você diz que se retirar 3 e 11 da coluba B dá 14, mas tem duas vezes o 3 na coluna B! O 11 você vai tirar porque, se ele não se repete?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe... acho que me compliquei na explicação anterior.

Mas é o seguinte:

Quais valores constam na "coluna A" e não constam na "coluna B" ?

Quais valores constam na "coluna B" e não constam na "coluna A"?

Porém, há casos que o valor repete mais de uma vez em determinada coluna e só aparece uma vez na outra coluna . Exemplificando de forma mais clara:(caso valor 1)

A B

1 1

2 1

3 4

4 9

5 3

15 18

Na "coluna A", os valores que não contam na "coluna B" são: 2 e 5.

Na "coluna B", os valores que não contam na "coluna A" são: 1 e 9.

Compartilhar este post


Link para o post
Compartilhar em outros sites

nao entendi muito bem...

mas pelo que eu entendi você resolveria isso muito fácil no access...

você só quer separar os valores de a que nao estão em b

e os valores de b que nao estão em a.

você quer tentar fazer isso no access?

porque até dá pra fazer no excel, mas fica uma formula cabulosa, sendo que no access você resolve com duas consultas...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sem problemas.... se tiver como fazer isso no Access, sem o menor problema.

Minha dificuldade é que faço o básico do básico no access.

Mas, gostaria sim se puder me ajudar.

Tenho que mostrar um trabalho pro meu chefe em que cada coluna tem mais ou menos 5.000 dados.

Qualquer ajuda.... alanreisdf@hotmail.com

Valeu mesmo !

Compartilhar este post


Link para o post
Compartilhar em outros sites

Na primeira condição, você coloca a seguinte formula (para ver se os valores de A estão em B, faça esta formatação em A1 e depois copie a célula e cole especial Formatos nas outras células da coluna A:

=SE(ÉERROS(PROCV(A1;B:B;1;0));1;0)

Para as da coluna B, você utiliza a formula seguinte na B1 e copia para todas as outaso somente formato.

=SE(ÉERROS(PROCV(B1;A:A;1;0));1;0)

Lembrando que você tem que definir uma cor na formatação condicional para quando o valor não for encontrado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá gostaria de saber se alguém consegue resolver meu problema, tenho duas colunas e preciso comparar as duas vendo se nºs que existem em uma constam na outra e os que não constarem que sejam jogados em outra coluna.

Alguém saberia me informar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×