Ir ao conteúdo
  • Cadastre-se
INEM

[Resolvido] Visual basic 2008 "progressbar"

Recommended Posts

Olá pessoal, eu estou a fazer um browser simples em Visual Basic 2008 express, e queria acrescentar em baixo um progressbar, para quando uma página fosse carregada se vi-se a barra de progresso a funcionar!

Como não sei o código que deve colocar, será que alguém me o pode dizer?!

abraços

INEM

Compartilhar este post


Link para o post
Compartilhar em outros sites

Há muitas maneiras de fazer uma ProgressBar. Eu já vi sistemas em que a ProgressBar era apenas um gif.

Agora se você quiser uma que funcione como deveria, pode começar por aqui.

http://support.microsoft.com/kb/323088/pt-br

http://www.macoratti.net/vbn_pb1.htm

http://www.vbdotnetheaven.com/UploadFile/mahesh/ProgressBar04262005051817AM/ProgressBar.aspx

http://www.java2s.com/Code/VB/GUI/Progress-Bar.htm

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boas coloquei um timer para o progressbar e está a funcionar, mas o problema é que está muito rápido, quase nem dá para ver ele a funcionar, o que devo mudar?!

O código está assim:

Private Sub ProgressBar1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ProgressBar1.Click

If (Me.ProgressBar1.Value > 0) Then

Me.ProgressBar1.Value -= 1

Me.ProgressBar1.Value += 1

Else

Me.Timer3.Enabled = True

End If

End Sub

Private Sub Timer3_Tick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Timer3.Tick

Me.ProgressBar1.Value = 100

Me.ProgressBar1.Value = 0

Me.Timer3.Interval = 1

Me.Timer3.Enabled = True

End Sub

Obrigada desde já pelas possiveis ajudas

INEM

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mude a propriedade Interval do Timer.

No timer o valor é medido em milisegundos, ou seja, .Interval = 1000 significa 1 segundo.

No seu exemplo ficaria algo assim:

Me.Timer3.Interval = 5000 (5 segundos)

Editado por joaogabriel

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigada pela resposta, joaogabriel, já está a funcionar como eu quero :)

abraços

INEM

P.S. Podem fechar o tópico por favor, Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso Resolvido! Caso o autor do tópico necessite poderá entrar em contato com a moderação solicitando a re-abertura deste tópico.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×