Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
marquimrlz

Ajuda com Pagina e script

Recommended Posts

Ola, estou tentando ja faz algum tempo arrumar uma pagina que executa uma função...

Tentarei explicar, estou tentando inserir um link para executar uma função quando a pessoa loga com uma conta que esta setada admin...

Mas acontece que o link para executar essa função, não aparece na pagina quando o admin loga..

Parte do Código:

function/main.php


if ($_SESSION['sesadmin'] == "1") {
$logpanel = '
<!-- Box GM Panel Top -->
<table style="background-image: url('.$skindir.'cat_back.gif);" class="tcat" border="0" cellpadding="0" cellspacing="0" width="100%">
<tbody>
<tr>
<td align="left" height="35" valign="top" width="16"><img title=" " src="'.$skindir.'cat_top_ls.gif" alt=" " border="0" height="35" width="16"></td>
<td align="left" valign="middle" width="125"><strong></strong></td>
<td align="right" height="35" valign="top" width="34"><img title=" " src="'.$skindir.'cat_top_rs.gif" alt=" " border="0" height="35" width="34"></td>
</tr>
</tbody>
</table>
<!-- End Box GM Panel Top -->
<table class="tborder" align="center" border="0" cellpadding="20" cellspacing="10" height="100%" width="100%">
<tbody id="" style="">
<tr align="center">
<td class="thead">'.$lang['gmpanel'].'</td>
</tr>
<tr align="left">
<td class="alt1">
<div>• <a href="index.php?act=admin&actu=money">Money Edit</a></div>
<div>• <a href="index.php?act=admin&actu=skillcharedit">Skill Edit</a></div>
<div>• <a href="index.php?act=admin&actu=statcharedit">Stats Edit</a></div>
<div>• <a href="index.php?act=admin&actu=member">Member Info</a></div>
[U]<[B]div>• <a href="index.php?act=admin&actu=chkinn">Checar Dupe Inhostess</a></div>
<div>• <a href="index.php?act=admin&actu=chkinv">Checar Dupe Inventory</a></div> [/B][/U]
</td>
</tr>
</tbody>
</table>
<!-- Box GM Panel Bottom -->
<table class="thead" cellpadding="0" cellspacing="0" width="100%">
<tbody>
<tr>
<td height="5" width="100%"><img title=" " src="'.$skindir.'trans.gif" alt=" " border="0" height="5"></td>
</tr>
</tbody>
</table>
<!-- End Box GM Panel Bottom -->

<div><img src="'.$skindir.'clear.gif" height="4"></div>';
}

Essas ultimas duas funções eu estou tentando colocar, mas elas não aparecem quando a pessoa loga como admin no painel do site, essas duas que estão sublinhadas...

siteruimdo4.jpg

Editado por marquimrlz
Removido um script e adicionado uma imagem

Compartilhar este post


Link para o post
Compartilhar em outros sites

$_SESSION['sesadmin'] != 1

AAah, não prestei atenção... pelo que parece, o "1" é o código de administração

o != é de diferença, logo if($_SESSION['sesadmin'] é diferente de 1){... }

entendeu?

Usa

$_SESSION['sesadmin'] == "1"

põe o "" e == no lugar do !=.

Se não funcionar, da um echo $_SESSION['sesadmin']; e ve qual valor aparece.

Editado por Rondnelly

Compartilhar este post


Link para o post
Compartilhar em outros sites
$_SESSION['sesadmin'] != 1

AAah, não prestei atenção... pelo que parece, o "1" é o código de administração

o != é de diferença, logo if($_SESSION['sesadmin'] é diferente de 1){... }

entendeu?

Usa

$_SESSION['sesadmin'] == "1"

põe o "" e == no lugar do !=.

Se não funcionar, da um echo $_SESSION['sesadmin']; e ve qual valor aparece.

Essa parte: admin.php

Esta funcionando bem, aquele != 1 é porque se for diferente de 1 que é admin ele executa o comando die.

Senão ele executa os comandos, essa parte de admin ta funcionando eu ja testei ela digitando a função na barra de endereço, o que esta acontecedendo é que os dois comandos:

<div>• <a href="index.php?act=admin&actu=chkinn">Checar Dupe Inhostess</a></div>

<div>• <a href="index.php?act=admin&actu=chkinv">Checar Dupe Inventory</a></div>

do script main.php não esta aparecendo na pagina, enquanto os outros estão, normalmente.

Segue imagem:

siteruimdo4.jpg

Eu só coloquei o script admin;php porque achei que poderia ajudar a solucionar o problema...

Enfim o problema é meus dois comandos não aparecerem na pagina...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×